Opened 12 years ago

Closed 11 years ago

#1166 closed bug (fixed)

Open with -> ArtPaint crashes app_server

Reported by: jonas.kirilla Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

Selecting a couple of screenshots in Tracker, right-clicking them and choosing Open with > ArtPaint, app_server crashes.

Attachments (2)

ArtPaint and app_server.txt (1.5 KB) - added by jonas.kirilla 12 years ago.
Serial debugging output
app_server and eight copies of font demo.txt (53.9 KB) - added by jonas.kirilla 12 years ago.

Download all attachments as: .zip

Change History (10)

Changed 12 years ago by jonas.kirilla

Attachment: ArtPaint and app_server.txt added

Serial debugging output

comment:1 Changed 12 years ago by axeld

Description: modified (diff)

What is a couple? And what version of ArtPaint are you using? I just tried with ArtPaint 2.0 from BeBits (http://www.bebits.com/app/3325), but I couldn't reproduce the problem (with up to 4 screen shots).

comment:2 in reply to:  1 Changed 12 years ago by jonas.kirilla

Replying to axeld:

What is a couple? And what version of ArtPaint are you using?

Any number should do. It crashes for me on opening a single image as well. It's version 1.3. Available in BeShare. The same version hangs sometimes on the second window, in BeOS (R5/Bone), when opening 4 images. FWIW.

comment:3 Changed 12 years ago by jonas.kirilla

Haiku's FontDemo is another user of floating palette windows and crashes in the same way as ArtPaint.

If you make copies of FontDemo (8-32 should do) and launch them together you should be able to see the app_server crash in WindowLayer::Frontmost() in a server thread corresponding to a floating palette window.

FontDemo::FontDemo()
	: BApplication("application/x-vnd.Haiku-FontDemo")
{
	// Create the demo window where we draw the string
	BWindow* demoWindow = new BWindow(BRect(80, 30, 490, 300), "FontDemo",
		B_TITLED_WINDOW, B_ASYNCHRONOUS_CONTROLS | B_QUIT_ON_WINDOW_CLOSE);

	FontDemoView* demoView = new FontDemoView(demoWindow->Bounds());
	demoWindow->AddChild(demoView);

	BWindow* controlWindow = new BWindow(BRect(500, 30, 700, 402), "Controls",
		B_FLOATING_WINDOW_LOOK, B_FLOATING_APP_WINDOW_FEEL,
		B_NOT_CLOSABLE | B_NOT_ZOOMABLE | B_NOT_RESIZABLE | B_ASYNCHRONOUS_CONTROLS);

	ControlView* controlView = new ControlView(controlWindow->Bounds());
	controlWindow->AddChild(controlView);

	controlView->SetTarget(demoView);

	demoWindow->Show();	
	controlWindow->Show();
}

Changed 12 years ago by jonas.kirilla

comment:4 Changed 12 years ago by jonas.kirilla

BTW, feel free to change the summary and description to better fit the root cause.

comment:5 Changed 12 years ago by jonas.kirilla

This still happens in hrev22149. Opening 7 copies of FontDemo simultaneously will crash the app_server. Anyway, this looks like a duplicate of #195 and #266. Sorry about that.

comment:6 Changed 11 years ago by julun

I this bug still valid? I tested today with 8 copies of FontDemo and it did not crash.

Karsten

comment:7 Changed 11 years ago by stippi

Could be fixed by hrev28224. Can you still reproduce it, Jonas?

comment:8 Changed 11 years ago by julun

Resolution: fixed
Status: newclosed

Can't reproduce anymore, though no idea when it got fixed.

Note: See TracTickets for help on using tickets.