Opened 14 years ago

Closed 12 years ago

#195 closed bug (fixed)

[app_server] crash in WindowLayer::Frontmost()

Reported by: diver Owned by: axeld
Priority: blocker Milestone: R1/alpha1
Component: Servers/app_server Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by wkornewald)

This was while playing around desktop icons (renaming, Get info, etc). Dunno how to reproduce it yet. Screenshot will follow. Tested with rev16455 under wmvare.

Attachments (1)

app_server_crash.PNG (25.6 KB) - added by diver 14 years ago.
debug shot

Download all attachments as: .zip

Change History (25)

Changed 14 years ago by diver

Attachment: app_server_crash.PNG added

debug shot

comment:1 Changed 13 years ago by marcusoverhagen

severity: majorblocker

comment:2 Changed 13 years ago by marcusoverhagen

Changing the severity to "blocker" as this problem crashes the whole system.

comment:3 Changed 13 years ago by marcusoverhagen

Probably fixing #266 will also fix this problem, as crash is both times in WindowLaxer::Frontmost()

comment:4 Changed 13 years ago by marcusoverhagen

dependson: 266

comment:5 Changed 13 years ago by marcusoverhagen

Status: newclosed

comment:6 Changed 13 years ago by marcusoverhagen

should be fixed now

comment:7 Changed 13 years ago by marcusoverhagen

Resolution: fixed

comment:8 Changed 13 years ago by diver

Happens again, see attachment 322 in #266 Reopening...

comment:9 Changed 13 years ago by diver

Resolution: fixed
Status: closedreopened

comment:10 Changed 13 years ago by diver

Summary: app_server crashapp_server in WindowLayer::Frontmost()

comment:11 Changed 13 years ago by diver

Summary: app_server in WindowLayer::Frontmost()app_server crash in WindowLayer::Frontmost()

comment:12 Changed 13 years ago by diver

Ok, some more information, to speed up this crash press Be Menu-Preferences Select all prefs and start them at once, while they loading switch workspaces (alt+f1, alt+f2) and press team window to select them (as described in #757)

comment:13 Changed 13 years ago by diver

(In reply to comment #6) Well, now i just dead lock app_server this way, so it seems that this bug would be more easy to reproduce after #757 will be fixed ;-)

comment:14 Changed 13 years ago by diver

Summary: app_server crash in WindowLayer::Frontmost()[app_server] crash in WindowLayer::Frontmost()

comment:15 Changed 13 years ago by axeld

Component: GeneralUser Interface/Application Server
Description: modified (diff)
Platform: All

comment:16 Changed 13 years ago by wkornewald

Description: modified (diff)

typo

comment:17 in reply to:  14 Changed 13 years ago by diver

OK, bug #757 is fixed and i can reproduce this bug again now, cool ;-)

comment:18 Changed 13 years ago by axeld

I tried a number of times, but I can't reproduce it over here using the technique that triggered bug #757. Are you doing anything differently here?

comment:19 Changed 13 years ago by diver

It seems that now you have to open more apps to crash app_server. Try opening /boot/beos/apps at once and while they are loading start to switch workspaces and clicking team menu.

comment:20 Changed 12 years ago by stippi

Is this one still reproducable?

comment:21 Changed 12 years ago by stippi

Oh, yeah it is. Sorry for spamming.

comment:22 Changed 12 years ago by axeld

Milestone: R1R1/alpha

comment:23 Changed 12 years ago by stippi

I have been working on this bug by changing the locking a bit in app_server. The weird thing is that this crashing bug does not happen in the test_environment. Try running all sorts of apps, including stress_test which opens windows like crazy and then switching workspaces works fine. At least after I fixed a couple of deadlocks which were more easily provoked with my locking changes. When I try this on Haiku though, most apps will hang and not open any window anymore, so I must have messed something up. I will try again with the recent fixes to the kernel and post my results here.

comment:24 Changed 12 years ago by axeld

Resolution: fixed
Status: reopenedclosed

Fixed in hrev22549.

Note: See TracTickets for help on using tickets.