Opened 4 years ago

Closed 5 months ago

#11684 closed bug (duplicate)

Boot failure : PANIC: Fatal exception "NMI Interrupt" occurred

Reported by: ismarkin Owned by: nobody
Priority: normal Milestone: R1
Component: System Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: #4555 Blocking:
Has a Patch: no Platform: All

Description

Boot fails with nightly haiku-nightly-hrev48590-x86_gcc2_hybrid-anyboot.zip on an USB stick. KDL prompt is displayed. I typed "co" but the OS did not boot completly.

I got kernel output traces from serial link and lspci output from Linux on this computer.

Attachments (3)

lspci.txt (6.1 KB) - added by ismarkin 4 years ago.
haiku_kernel_traces.txt (87.5 KB) - added by ismarkin 4 years ago.
boot_haiku_20150106.log (206.9 KB) - added by ismarkin 4 years ago.
boot logs

Download all attachments as: .zip

Change History (11)

Changed 4 years ago by ismarkin

Attachment: lspci.txt added

Changed 4 years ago by ismarkin

Attachment: haiku_kernel_traces.txt added

comment:1 Changed 4 years ago by waddlesplash

Blocking: 7665 added

According to your syslog, it appears package_daemon mounted everything and the video driver (intel_extreme) was just starting when the KDL occured. I couldn't find anything else useful.

comment:2 Changed 4 years ago by pulkomandy

waddlesplash, you didn't look close enough. The panic is earlier in the log (as mentionned in the ticket "co" was typed to try to continue booting). It happens during initialization of the PCI bus.

What do you mean by "did not boot completely"? If you get a black screen, you may need to use failsafe video mode or blacklist the intel_extreme driver. Note that you may still need to type "co" to get past the panic in that case. If you get something else than a black screen, please be more specific.

comment:3 Changed 4 years ago by diver

Component: - GeneralSystem
Platform: x86All

comment:4 Changed 4 years ago by ismarkin

I made two new tests. You can find the logs in boot_haiku_20150106.log file. Attempt 1 :

  • normal boot without failsafe video mode
  • after KDL crash I typed 'co'
  • i saw the 7 icons displayed (the last one was a rocket)
  • a second KDL occured
  • I typed again 'co'
  • startup continues but I got a blank screen I could do nothing
  • I pressed my computer restart button

Attempt 2 :

  • at boot selected failsafe video mode
  • got the KDL crash
  • I typed co
  • startup continues

I could start installation process. But it was very slow. I could get the partion manager application. I don't manage to create a new partition. I stopped at this point

Changed 4 years ago by ismarkin

Attachment: boot_haiku_20150106.log added

boot logs

comment:5 Changed 4 years ago by waddlesplash

Looks like a duplicate of #4555.

comment:6 Changed 11 months ago by waddlesplash

Keywords: boot-failure added

comment:7 Changed 11 months ago by waddlesplash

Blocking: 7665 removed

comment:8 Changed 5 months ago by waddlesplash

Blocked By: 4555 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.