Opened 6 years ago

Closed 5 years ago

#11772 closed bug (duplicate)

close_fd() page fault

Reported by: ttcoder Owned by: bonefish
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: #4473 Blocking:
Platform: All

Description

Looks like some backtraces from #4157 deps

hrev48411

First time we see that one but we'll try to eventually get rid of /bin/wget forking/utilization and use native sockets instead, anyway.

Attachments (2)

IMG_3694.JPG (225.9 KB ) - added by ttcoder 6 years ago.
FullSizeRender.jpg (270.3 KB ) - added by ttcoder 6 years ago.
same computer as before

Download all attachments as: .zip

Change History (7)

by ttcoder, 6 years ago

Attachment: IMG_3694.JPG added

comment:1 by anevilyak, 6 years ago

Component: - GeneralSystem/Kernel
Owner: changed from nobody to bonefish
Status: newassigned

Most likely a duplicate of #4473 (taking into account team cleanup refactoring in the intervening years), but I'll let bonefish make the call there.

by ttcoder, 6 years ago

Attachment: FullSizeRender.jpg added

same computer as before

comment:2 by ttcoder, 6 years ago

That second one is clearly a duplicate of 4473 (?), crashes in put_fd() instead of close_fd()

Anyway that's odd, we never saw that before and today, occurs twice in a row on a machine we meant to ship. Investigating as to how that machine differs from others..

PS. the KDL lists Terminal, but occured at the time a Tracker window was closed, reportedly

Last edited 6 years ago by ttcoder (previous) (diff)

comment:3 by ttcoder, 6 years ago

dsuden did a pkgman update today (so to 48700+ whereabouts) and it has not KDL'ed yet; we're going to ship it; the improvement could be due to...

  • some kernelland fixes in that rev range, or (more likely I suppose)
  • the fact that re-ordering packages sometimes exposes bugs that were hidden, as observed by a few people during the last few months.

(edit: the helpful *g* contribution below might be referring to this: ticket:11666#comment:3)

Last edited 6 years ago by ttcoder (previous) (diff)

in reply to:  3 comment:4 by anevilyak, 6 years ago

Replying to ttcoder:

  • the fact that re-ordering packages sometimes exposes bugs that were hidden, as observed by a few people during the last few months.

Please stop making this your boogeyman for every sporadically reproducible problem you encounter. The only instance where file order is actually relevant is for add-ons, and in the specific cases where it occurred it was because two different add-ons claimed support for the same format with the same priority. This is a very special case scenario that only really comes into play for the media kit and translation kit, and isn't relevant in pretty much any other scenario, so please stop jumping on it at every possible chance as you seem to have developed a tendency to do in recent weeks.

comment:5 by diver, 5 years ago

Blocked By: 4473 added
Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.