Opened 4 years ago

Closed 4 years ago

#12164 closed bug (duplicate)

DHCP don't work

Reported by: X512 Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: Network & Internet/Stack Version: R1/Development
Keywords: Cc:
Blocked By: #12156 Blocking:
Has a Patch: no Platform: All

Description

This is hrev49297.

DHCP don't work anymore (shown as endlessly configuring). It worked in previous revisions, but unstable.

Hardware is Intel wired Ethernet adapter:

device Network controller (Ethernet controller) [2|0|0]
  vendor 8086: Intel Corporation
  device 153b: Ethernet Connection I217-V

Syslog:

DAEMON 'DHCP': /dev/net/ipro1000/0: Send DHCP_DISCOVER to 255.255.255.255:67
DAEMON 'DHCP': /dev/net/ipro1000/0: Received DHCP_OFFER from 192.168.10.1
DAEMON 'DHCP':   your_address: 192.168.10.100
DAEMON 'DHCP':   server: 192.168.10.1
DAEMON 'DHCP':   renewal time: 43200 seconds
DAEMON 'DHCP':   rebinding time: 75600 seconds
DAEMON 'DHCP':   lease time: 86400 seconds
DAEMON 'DHCP':   subnet: 255.255.255.0
DAEMON 'DHCP':   gateway: 192.168.10.1
DAEMON 'DHCP':   nameserver[0]: 192.168.10.1
DAEMON 'DHCP': /dev/net/ipro1000/0: Send DHCP_REQUEST for 192.168.10.100 to 255.255.255.255:67
DAEMON 'DHCP': /dev/net/ipro1000/0: Timeout shift: 8 secs (try 1)
DAEMON 'DHCP': /dev/net/ipro1000/0: Send DHCP_REQUEST for 192.168.10.100 to 255.255.255.255:67
DAEMON 'DHCP': /dev/net/ipro1000/0: Timeout shift: 16 secs (try 2)
DAEMON 'DHCP': /dev/net/ipro1000/0: Send DHCP_REQUEST for 192.168.10.100 to 255.255.255.255:67
DAEMON 'DHCP': /dev/net/ipro1000/0: Timeout shift: 32 secs (try 3)
DAEMON 'DHCP': /dev/net/ipro1000/0: Send DHCP_REQUEST for 192.168.10.100 to 255.255.255.255:67
DAEMON 'DHCP': /dev/net/ipro1000/0: Timeout shift: 64 secs (try 4)
DAEMON 'DHCP': /dev/net/ipro1000/0: Send DHCP_REQUEST for 192.168.10.100 to 255.255.255.255:67
DAEMON 'DHCP': /dev/net/ipro1000/0: Timeout shift: 64 secs (try 5)
DAEMON 'DHCP': /dev/net/ipro1000/0: Send DHCP_REQUEST for 192.168.10.100 to 255.255.255.255:67
Last message repeated 1 time
DAEMON 'DHCP': /dev/net/ipro1000/0: Timeout shift: 8 secs (try 1)
DAEMON 'DHCP': /dev/net/ipro1000/0: Send DHCP_REQUEST for 192.168.10.100 to 255.255.255.255:67
DAEMON 'DHCP': /dev/net/ipro1000/0: Timeout shift: 16 secs (try 2)
DAEMON 'DHCP': /dev/net/ipro1000/0: Send DHCP_REQUEST for 192.168.10.100 to 255.255.255.255:67
DAEMON 'DHCP': /dev/net/ipro1000/0: Timeout shift: 32 secs (try 3)
DAEMON 'DHCP': /dev/net/ipro1000/0: Send DHCP_REQUEST for 192.168.10.100 to 255.255.255.255:67
DAEMON 'DHCP': /dev/net/ipro1000/0: Timeout shift: 64 secs (try 4)
DAEMON 'DHCP': /dev/net/ipro1000/0: Send DHCP_REQUEST for 192.168.10.100 to 255.255.255.255:67

Internet is working in Windows. Bug reason is maybe the same as in #11607, #12156.

Change History (3)

comment:1 by vidrep, 4 years ago

Possible duplicate of ticket #12161 as well.

comment:2 by X512, 4 years ago

hrev49303 don't change anything.

comment:3 by pulkomandy, 4 years ago

Blocked By: 12156 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.