Opened 4 years ago

Closed 13 months ago

#12280 closed bug (fixed)

Failing to connect to a wifi ap results in the need for a reboot.

Reported by: kallisti5 Owned by: nobody
Priority: blocker Milestone: R1
Component: Network & Internet/Wireless Version: R1/Development
Keywords: WIFI key prop Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

if you enter the wrong key and fail connecting to a wifi network, you have to reboot and start over

This is a break-apart of the issues listed in #7660.

Attachments (1)

syslog (145.7 KB ) - added by cocobean 20 months ago.
syslog of iprowifi3945 driver/wpa_supplement 2.4 using hrev_51880

Download all attachments as: .zip

Change History (7)

comment:1 by mmlr, 4 years ago

Are you able to reproduce this issue? The implemented workflow is as follows:

1) Try finding a stored key for the selected network and try to connect using it 2) If the connection fails (timeout with no success notification) or there were no stored credentials, bring up the dialog 3) Try to connect using the supplied credentials 4) When a connection is established successfully, store the credentials, otherwise go back to 2

The wpa_supplicant is told to shut down the association attempt when the timeout occurs, which probably is the root cause of this issue. It is probably related to disabling/reenabling the interface in the FreeBSD compatibility layer and might therefore also be driver specific. What setup did you test on?

comment:2 by axeld, 4 years ago

Blocking: 7660 removed

comment:3 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:4 by cocobean, 20 months ago

Last edited 17 months ago by cocobean (previous) (diff)

by cocobean, 20 months ago

Attachment: syslog added

syslog of iprowifi3945 driver/wpa_supplement 2.4 using hrev_51880

comment:5 by scottmc, 15 months ago

can you recheck this with a recent Haiku build?

comment:6 by waddlesplash, 13 months ago

Resolution: fixed
Status: assignedclosed

Probably fixed with new wpa_supplicant; at least it works here. Closing as fixed.

Note: See TracTickets for help on using tickets.