Opened 4 years ago

Closed 9 months ago

#12281 closed bug (fixed)

wpa_supplicant can be crashed easily, and isn't restarted

Reported by: kallisti5 Owned by: axeld
Priority: blocker Milestone: R1
Component: Network & Internet/Wireless Version: R1/Development
Keywords: wpa_supplicant Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

wpa_supplicant can be crashed easily, and isn't restarted

This is a break apart of these R1 blockers from #7663 to make them more visible.

This might be something we can solve with the launch daemon.

Attachments (1)

P_20180413_175911[1].jpg (3.8 MB) - added by cocobean 12 months ago.
iprowifi3945 driver crash - kernel debugger snapshot

Change History (6)

comment:1 Changed 3 years ago by axeld

Blocking: 7660 removed

comment:2 Changed 13 months ago by pulkomandy

Is this still happening? During the latest coding sprint I finished mmlr's work on updating wpa_supplicant and I don't remember hitting this problem since then. I'm interested in debug reports if someone can reproduce it.

Changed 12 months ago by cocobean

Attachment: P_20180413_175911[1].jpg added

iprowifi3945 driver crash - kernel debugger snapshot

comment:3 Changed 12 months ago by cocobean

Last edited 12 months ago by cocobean (previous) (diff)

comment:4 Changed 12 months ago by cocobean

No system reboot issues with wpa_supplement on hrev51881 x86_64. Seems stable.

comment:5 Changed 9 months ago by waddlesplash

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.