Opened 4 years ago

Closed 2 years ago

Last modified 22 months ago

#12292 closed bug (duplicate)

No boot due to timeouts on Intel BX440 based SMP system

Reported by: Alexco Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Disk/ATA Version: R1/Development
Keywords: Cc:
Blocked By: #10253 Blocking:
Has a Patch: no Platform: All

Description

Haiku needs "no IDE DMA" option to successfully boot. Otherwise the system ends up KDL. See attached boot log for boot without and with DMA.

Attachments (2)

haiku_DMA.txt (39.6 KB) - added by Alexco 4 years ago.
Boot log with IDE DMA
haiku_NO_DMA.txt (85.9 KB) - added by Alexco 4 years ago.
Successful boot without IDE DMA

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by Alexco

Attachment: haiku_DMA.txt added

Boot log with IDE DMA

Changed 4 years ago by Alexco

Attachment: haiku_NO_DMA.txt added

Successful boot without IDE DMA

comment:1 Changed 4 years ago by waddlesplash

What hrev are you running? EDIT: nevermind, I see it's actually in the logs.

Last edited 4 years ago by waddlesplash (previous) (diff)

comment:2 Changed 4 years ago by Alexco

Ah, sorry forgot to mention. For the record (even if you already found it), installation was done using haiku-nightly-hrev49409-x86_gcc2_hybrid image.

comment:3 Changed 2 years ago by diver

Blocked By: 10253 added
Component: - GeneralDrivers/Disk/ATA
Resolution: duplicate
Status: newclosed

comment:4 Changed 22 months ago by Alexco

Please see #13620 for solution

Note: See TracTickets for help on using tickets.