Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1231 closed bug (fixed)

PCL6: Resizing Issue with Additional Add Printer Dialog

Reported by: katisu Owned by: laplace
Priority: normal Milestone: R1
Component: Printing Version: R1/pre-alpha1
Keywords: Cc: katisu@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When adding a PCL6 printer, an additional dialog shows up to select the protocol. If user scrolls the description text down for PCL 6 Protocol Class 1.1 and then resizes the dialog, the description text does not adjust. The result is the top text is cut off and can not be reached without making the dialog smaller again.

Attachments (2)

Image2.png (15.0 KB ) - added by katisu 12 years ago.
Scroll Problem
Image3.png (14.4 KB ) - added by katisu 12 years ago.
Select and Drag Problem

Download all attachments as: .zip

Change History (6)

comment:1 by laplace, 12 years ago

Resolution: fixed
Status: newclosed

Fixed with revision 21182. The text rectangle is updated when the view is resized.

by katisu, 12 years ago

Attachment: Image2.png added

Scroll Problem

by katisu, 12 years ago

Attachment: Image3.png added

Select and Drag Problem

comment:2 by katisu, 12 years ago

Problem still exists and found an additional issue. When selecting the text and dragging the text moves in the opposite direction. The second picture I added shows what happens when this is done and dragging to the left. I can't rule out this being a problem with Haiku's implementation of BScrollView or BTextArea, so when I get a chance I'll look into this some more. Leaving ticket closed for now.

comment:3 by laplace, 12 years ago

I cannot reproduce the problem(s) under BeOS R5. I suggest to create a new ticket for component Servers/app_server.

comment:4 by katisu, 12 years ago

Selection and drag issue is existent in the About This System Dialog which suggests these are in fact app server issues.

Following tickets created for component Servers/app_server Ticket #1240 created for selection and drag issue. Ticket #1241 created for scroll and resizing issue.

Note: See TracTickets for help on using tickets.