Opened 4 years ago

Closed 3 years ago

#12508 closed bug (duplicate)

MediaPlayer (64 bit) crashes on some AVI and MOV format videos

Reported by: vidrep Owned by: stippi
Priority: normal Milestone: Unscheduled
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc:
Blocked By: #12649, #12650, #12654 Blocking:
Has a Patch: no Platform: All

Description

hrev49888 x86_64 Some SD .avi and .mov format videos cause MediaPlayer to crash Opened MediaPlayer from terminal Test logs attached

test_AVI.log test1_AVI.log test_MOV.log

Attachments (10)

test_AVI.log (858 bytes ) - added by vidrep 4 years ago.
test1_AVI.log (458 bytes ) - added by vidrep 4 years ago.
test_MOV.log (437 bytes ) - added by vidrep 4 years ago.
ffmpeg2.8.3.log (1.4 KB ) - added by vidrep 4 years ago.
ffmpeg0.11.5.log (1.9 KB ) - added by vidrep 4 years ago.
screenshot1.png (498.2 KB ) - added by vidrep 4 years ago.
test.AVI (1.8 MB ) - added by vidrep 4 years ago.
MediaPlayer-569-debug-22-12-2015-15-37-51.report (72.9 KB ) - added by vidrep 4 years ago.
Fighter.mpg (2.1 MB ) - added by vidrep 4 years ago.
ffmpeg-688-debug-28-12-2015-19-54-59.report (64.4 KB ) - added by vidrep 4 years ago.

Change History (27)

by vidrep, 4 years ago

Attachment: test_AVI.log added

by vidrep, 4 years ago

Attachment: test1_AVI.log added

by vidrep, 4 years ago

Attachment: test_MOV.log added

comment:1 by vidrep, 4 years ago

Did a pkgman update from hrev49888 to hrev49893 and now HD videos which played before are causing MP to crash. Similar behavior was noted after updating x86_gcc2. I'll download hrev49893 and do a fresh install to see if it makes a difference compared to a pkgman update.

comment:2 by vidrep, 4 years ago

Before doing a fresh install, I did another pkgman update fromhrev49893 (not working) to hrev49894..and now it is working again! Should another ticket be opened to explore the possibility of build bot related corruption?

comment:3 by vidrep, 4 years ago

Doing a fresh install of hrev49893 restores the previous behaviour. Updating to hrev49893 using pkgman from a earlier revision causes MP to crash. There is another issue at play here that appears unrelated to the codec problem.

comment:4 by vidrep, 4 years ago

All oif the SD videos that crash MediaPlayer on recent 64 bit builds have one thing in common - raw audio. I went back to earlier builds and the issue starts with hrev49881.The previous available build available for download hrev49876 plays these files OK as do others I tested (49862, 49858 and 49844).

comment:5 by vidrep, 4 years ago

I have attached a pair of terminal logs of MediaPlayer trying to play the same video file:

ffmpeg2.8.3.log is output from hrev49911 x86_64 (crashing MediaPlayer)

ffmpeg0.11.5.log is output from last working build hrev49876 x86_64

I have also attached a screenshot showing the video file playing, about system, file info

Note: Most other videos I tested appear to work fine on 64 bit. Only this particular format appears to crash MediaPlayer.

Last edited 4 years ago by vidrep (previous) (diff)

by vidrep, 4 years ago

Attachment: ffmpeg2.8.3.log added

by vidrep, 4 years ago

Attachment: ffmpeg0.11.5.log added

by vidrep, 4 years ago

Attachment: screenshot1.png added

comment:6 by vidrep, 4 years ago

While the AVCodecDecoder revert fixed x86_gcc2, it broke 64 bit audio. Videos which previously played video and audio fine, now have audio that sounds like a machine gun. I presume it is because of different ffmpeg versions being used.

comment:7 by pulkomandy, 4 years ago

Please try again now that the revert is reverted in hrev49933. I hope the new code is ok for all ffmpeg versions and all file formats.

comment:9 by vidrep, 4 years ago

Try any of the videos at this link: http://wapwon.com/video/category/f22_air_show.html

comment:10 by vidrep, 4 years ago

I have attached a video file that causes an immediate crash of MediaPlayer (but only on 64 bit): Test.AVI

by vidrep, 4 years ago

Attachment: test.AVI added

comment:11 by vidrep, 4 years ago

As of hrev49937 every video regardless of format causes a MediaPlayer crash. I have attached a debug report and the corresponding video which caused one such crash.

by vidrep, 4 years ago

Attachment: Fighter.mpg added

comment:12 by vidrep, 4 years ago

I have narrowed the problem down to between hrev49935 (not crashing) and hrev49936 (crashing). While the videos played on hrev49935 do not crash, there is still an audio bug present. Simply typing "ffmpeg" into a terminal on hrev49936 and later will cause a crash. The videos will not play whatsoever.

Last edited 4 years ago by vidrep (previous) (diff)

comment:13 by vidrep, 4 years ago

I have attached a ffmpeg debug report using hrev49928 x86_64

comment:14 by pulkomandy, 4 years ago

Typing "ffmpeg" in Terminal doesn't crash here (x86_64, hrev49945). Can we solve the issues one at a time please? It looks like you have several problems, again.

So, first think first, ffmpeg (the binary) shouldn't crash in this way. ffmpeg support for modplug was added in the recipe for 0.10.14 and 2.7.2 (Sun Aug 30 14:47:39 2015 +0200 in HaikuPorts). There were no further changes in that area since then.

I can't reproduce this problem, so there must be a difference in how our respective x86_64 installs are setup. What could it be? I'm using the standard haikuports and haiku repos (both in "current" state) and just did a pkgman full-sync this morning.

I'm going to ignore all other problems until this one is fixed, otherwise we're not getting anywhere.

comment:15 by vidrep, 4 years ago

Let's close this ticket and address each individual issue separately, as per IRC discussion today.

comment:16 by vidrep, 3 years ago

I created three separate tickets to address each issue individually (#12649, #12650, #12654). This ticket can be closed or batched for reference.

comment:17 by korli, 3 years ago

Blocked By: 12649, 12650, 12654 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.