Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#12510 closed bug (fixed)

Web+ doesn't upload screenshots to HaikuDepot

Reported by: humdinger Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: #12467 Blocking: #12992
Has a Patch: no Platform: All

Description

This is hrev49872.

Uploading screenshots to HaikUDepot doesn't work anymore (at least I think it has worked in the past, but I've been using QupZilla a lot before the latest Web+ improvements). The site just shows those three blinking dots and never returns.

Attachments (2)

script_console.png (16.2 KB ) - added by humdinger 4 years ago.
Trying to upload a screenshot to BeVexed
webdepotuploading.txt (4.4 KB ) - added by humdinger 4 years ago.
output with debug net kit

Download all attachments as: .zip

Change History (15)

comment:1 by apl-haiku, 4 years ago

Hi @humdinger; are you able to see if there is something in the JavaScript console for the web page. That may help to indicate the source of the problem.

by humdinger, 4 years ago

Attachment: script_console.png added

Trying to upload a screenshot to BeVexed

comment:2 by humdinger, 4 years ago

Attached is a screenshot of the script console (there seems to be no copying from it implemented). I tried to upload another screenshot to BeVexed. It stalls quite a while before ending in https://depot.haiku-os.org/error.

Last edited 4 years ago by humdinger (previous) (diff)

comment:3 by pulkomandy, 4 years ago

The console output is also sent to Terminal if you run Web+ there (but a copy button would be a nice addition). In this case, I think it would be more interesting to run with the network kit built in debug mode, which will trace a lot of things (all http requests) to the Terminal.

comment:4 by humdinger, 4 years ago

Hope I got it right, I put SetConfigVar DEBUG : HAIKU_TOP src kits network : 1 : global ; into my UserBuildConfig. Attached is the Wep+ output after hitting the "Add" button on the screenshot page of the HaikuDepot Server, complete with the falling back to the error page.

by humdinger, 4 years ago

Attachment: webdepotuploading.txt added

output with debug net kit

comment:5 by diver, 4 years ago

MESSAGE https://depot.haiku-os.org/jawr/js/gzip_540832521/bundles/libs.js?:121:325: unable to add the screenshot for; bevexed
MESSAGE https://depot.haiku-os.org/jawr/js/gzip_540832521/bundles/libs.js?:121:325: reset the breadcrumb stack

Have you tried with other browsers?

comment:6 by humdinger, 4 years ago

Yep. Works with Qupzilla.

comment:7 by apl-haiku, 4 years ago

I'm looking at the "Content-Length" value of "1925622312" in that trace at line 10 and wondering if that is correct. If I am not mistaken that's quite large at around 1.7GB. That is quite a bit for a screenshot. Could there be some problem there? Looking on the server-side at this time, I see the server logs;

2015-12-01 16:38:32.019:WARN:oejs.ServletHandler:qtp21796458-397: /pkgscreenshot/bevexed/add
java.io.IOException: java.util.concurrent.TimeoutException: Idle timeout expired: 30000/30000 ms
        at org.eclipse.jetty.server.HttpInput$ErrorState.noContent(HttpInput.java:745)
        at org.eclipse.jetty.server.HttpInput.read(HttpInput.java:157)

This could be because the header on the HTTP request is stating a larger quantity than is being delivered on the HTTP request body. The server is probably left waiting for those additional bytes to arrive and eventually times-out. @humdinger; what was the _actual_ size of that screenshot upload?

in reply to:  7 comment:8 by humdinger, 4 years ago

Replying to apl-haiku:

@humdinger; what was the _actual_ size of that screenshot upload?

For the test, I tried to re-upload the existing screenshot I downloaded before. It's size is 26,469 bytes.

comment:9 by humdinger, 4 years ago

JFYI: Still here with hrev50087.

comment:10 by pulkomandy, 4 years ago

Blocked By: 12467 added

comment:12 by pulkomandy, 4 years ago

Resolution: fixed
Status: newclosed

comment:13 by pulkomandy, 3 years ago

Blocking: 12992 added

(In #12992) Most likely duplicate of #12510, this seems to work in the current development build of WebKit.

Note: See TracTickets for help on using tickets.