Opened 4 years ago

Closed 23 months ago

#12677 closed bug (fixed)

Haiku is now slow to boot (it hangs for a while at the disk icon)

Reported by: Giova84 Owned by: nobody
Priority: normal Milestone: R1/beta1
Component: Drivers/Disk Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Hi,

Are passed about 5 weeks since the first time that I noticed this issue. I recently back on Haiku (since hrev50067); the last time that I run Haiku was about one year ago.

Well, since hrev50067 Haiku take a long time (compared to the past) to boot: it hangs for about 12 - 13 seconds at the disk icon. I tried an old hrev (hrev49662) and the boot time was fast as usual.

I reported this issue firstly in #12258 You can see my comment here: ticket:12258#comment:38 but the launch_daemon is not the culprit (launch_daemon is related to the rocket icon, and the issue, for me, is related to the disk icon)

Then the other guys (eg Humdinger here ticket:12258#comment:41) in such ticket told me that the culprit could be #12634 (the syslog is continuously flooded with the same messages - see also #12415)

I also tried to cleaning the old "state" directories in /system/packages/administrative because when this folder grows, could cause a slow boot.

Today, since I was thinking that the culprit would be #12415 I also uninstalled my optical drive (and disabled the SATA port in the BIOS): so now I no longer experienced the issue with the syslog which keeps growing, but the boot time is still slow.

Now, since I made the described workaround (uninstalled the optical drive) the syslog is no longer spammed and I attach the new clean version.

hrev50141

Attachments (1)

syslog (161.6 KB ) - added by Giova84 4 years ago.

Download all attachments as: .zip

Change History (18)

by Giova84, 4 years ago

Attachment: syslog added

in reply to:  description comment:1 by Giova84, 3 years ago

Replying to Giova84:

since hrev50067 Haiku take a long time (compared to the past) to boot: it hangs for about 12 - 13 seconds at the disk icon.

I forgot to mention the fact that recently I tried to disable the automount of my partitions (2 haiku disks, 1 ntfs disk and 1 fat 32 disk) but Haiku still shows a 12 - 13 seconds of delay to the disk icon during the boot process.

comment:2 by Giova84, 3 years ago

I have a news about this ticket:

today I switched from hrev50440 to hrev50480 and I noticed that the boot process lingers less seconds at the disk icon: until hrev50440 it paused about 13 seconds at the disk icon; now on hrev50480 it takes "only" about 9 seconds: however compared to the past is still slower.

comment:3 by diver, 3 years ago

Component: System/Boot LoaderDrivers/Disk
Milestone: UnscheduledR1
Owner: changed from axeld to nobody

I have the same problem on all my computers under VirtualBox. I believe it's an AHCI regression from fixing #12295 introduced in hrev49590. It probably deserves to be fixed before beta1.

comment:4 by Giova84, 3 years ago

Hi Diver,

You said that this trouble deserve to be fixed before beta1 but you set the target to R1; shouldn't this be set to the R1/Beta1 milestone instead? https://dev.haiku-os.org/milestone/R1/beta1

comment:5 by Giova84, 3 years ago

hrev51051 This issue is still present: however I noticed that if, in the BIOS settings I switch the controller from AHCI mode to IDE mode, Haiku will boot fast as usual (well, not very fast as usual, but it hangs for few seconds at the disk icon, about 4 - 5 seconds instead of 12 - 13 seconds)

comment:6 by diver, 3 years ago

Milestone: R1R1/beta1

For the same reason I stopped shutting down my VM and uses suspend now. So it's _really_ annoying. Maybe we can revert those changes for now? Bumping milestone as slow boot times like should be avoided for the release.

comment:7 by axeld, 3 years ago

I can't reproduce this with VirtualBox. Is it possible that you have a (virtual) CD-ROM attached to the system? If so, removing that might fix the issue for you. At least it only waits for about 2 seconds on the disk icon here.

IIRC kallisti5's changes to the AHCI port reset caused some issues with CD-ROMs, but I don't know if that has been fixed yet.

in reply to:  7 comment:8 by Giova84, 3 years ago

Replying to axeld:

I can't reproduce this with VirtualBox. Is it possible that you have a (virtual) CD-ROM attached to the system? If so, removing that might fix the issue for you.

As I stated in this ticket, since the bug with the optical drive was fixed time ago (see ticket:12634 and ticket:12415 ) However on this ticket where we are now, in my first message I said:

I also uninstalled my optical drive (and disabled the SATA port in the BIOS): so now I no longer experienced the issue with the syslog which keeps growing, but the boot time is still slow.

So: removing the optical drive doesn't fix the delay at the disk icon during boot.

For now, as I've said, I switched my controller, in the BIOS, from AHCI to IDE, but is a worst regression for me :-) So I grabbed the ahci driver from hrev49144 and I installed it in the non-packaged directories and now Haiku just hangs about 5 - 7 seconds at the disk icon during boot.

IIRC kallisti5's changes to the AHCI port reset caused some issues with CD-ROMs, but I don't know if that has been fixed yet.

Yes, as I've said was fixed :-) see ticket:12634#comment:3

comment:9 by diver, 3 years ago

I can reproduce it both with VirtualBox and VMware Fusion (no CD connected). Switching controller to IDE mode doesn't help.

comment:10 by axeld, 3 years ago

Then I wonder why I don't see the problem. Can someone share his problematic VirtualBox configuration for inspection?

in reply to:  10 comment:11 by Giova84, 3 years ago

Replying to axeld:

Can someone share his problematic VirtualBox configuration for inspection?

Ok, I've been able to reproduce this issue on VirtualBox too: on VirtualBox, for me, Haiku hangs for about 13 - 14 seconds at the disk icon, as it happens on real hardware for me. I downloaded the anyboot image (hrev51090 gcc2_hybrid), I setup this image, in VirtualBox, as optical drive on a SATA controller and I installed it on a vdi disk, always on the same SATA controller. Haiku will hangs however for a lot of seconds on the disk icon also if I will remove the optical drive from VirtualBox.

Here Vbox configuration in a zip file (there are also presents the logs files of Virtual Box): http://softwaredepot.altervista.org/upload/Haiku_VBOX.zip

comment:12 by Giova84, 2 years ago

Update: I installed Haiku on an SSD and now it take about 2 seconds to the disk icon during boot. Is ok, or should be even faster?

comment:13 by waddlesplash, 2 years ago

Well ... if you can't reproduce anymore, then I'd vote to close. Diver, what's the status on your end? (Has VirtualBox 5.2 fixed this?)

comment:14 by diver, 2 years ago

Yes, I can't reproduce it in VirtualBox 5.2 (with both IDE and AHCI controllers). However this is still the case with VMware Fusion

comment:15 by waddlesplash, 2 years ago

Can it be considered "not a problem" enough to bump this ticket out of b1 then?

comment:16 by diver, 2 years ago

Dunno, since I can't use vbox on my MacBook Pro (window moving is extremely slow due to retina display) I switched to VMware Fusion a few years ago. Maybe it's better to revert those commits that broke it.

comment:17 by diver, 23 months ago

Resolution: fixed
Status: newclosed

Moved my issue to #13811. Closing this one.

Note: See TracTickets for help on using tickets.