Opened 3 years ago

Closed 15 months ago

#13019 closed enhancement (no change required)

Haiku Installer Cannot Install Mounted Volume like BeOS

Reported by: vidrep Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Applications/Installer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Mount a Haiku Installation CD on the desktop Launch Haiku Installer app There is no possibility to install to a hard drive partition from the mounted volume. This was possible in BeOS (see attached screenshot)

Attachments (1)

BeOS_Installer.jpg (68.1 KB) - added by vidrep 3 years ago.

Download all attachments as: .zip

Change History (10)

Changed 3 years ago by vidrep

Attachment: BeOS_Installer.jpg added

comment:1 Changed 3 years ago by vidrep

Welcome to the Haiku shell.

~> ls /dev/disk/*/* /dev/disk/*/*/* ; mountvolume ; df -h
/dev/disk/ata/0:
master

/dev/disk/ata/0/master:
0  1  1_0  1_1  1_2  1_3  1_4  2  3  raw

/dev/disk/atapi/1:
master

/dev/disk/atapi/1/master:
raw
Volume                    File System            Size Mounted At (Device)
------------------------------------------------------------------------------
nightly                   Be File System        25.9G /boot  (ata/0/master/0)
Alpha 1                   Be File System        20.7G (ata/0/master/1_0)
Alpha 2                   Be File System        16.7G (ata/0/master/1_1)
Alpha 3                   Be File System        13.1G (ata/0/master/1_2)
Alpha 4                   Be File System        26.5G (ata/0/master/1_3)
BeOS R5                   Be File System        25.0G (ata/0/master/1_4)
BeOS R5.1d0               Be File System        28.2G (ata/0/master/2)
Zeta 1.5.1                Be File System        28.9G (ata/0/master/3)
Haiku                     ISO9660 File System   379.9M /Haiku  (atapi/1/master/raw)
Mount           Type      Total     Free     Flags   Device
--------------- -------- --------- --------- ------- --------------------------
/boot           bfs          25.9G     24.6G QAM-P-W /dev/disk/ata/0/master/0
/boot/system    packagefs      4.0K      4.0K QAM-P-- 
/boot/home/config 
                packagefs      4.0K      4.0K QAM-P-- 
/Haiku          iso9660     379.9M         0 ----P-- /dev/disk/atapi/1/master/raw
~> 
Last edited 3 years ago by pulkomandy (previous) (diff)

comment:2 Changed 3 years ago by vidrep

After many hours of installs I have found that there are two main factors at play here:

  1. Pre-Package management (PPM) vs Package management (PM) builds
  2. Anyboot (BeFS) image vs CD ISO (ISO9660) image

PM was merged in hrev46113

PM builds will install any mounted PM anyboot-image to a hard drive partition, but NOT a CD ISO image. (The CD ISO image will not be visible in the "install from:" selection in the Installer).

PM builds will install any mounted PPM anyboot-image to a hard drive partition, however it will NOT boot. You will get an error message "Failed to load OS. Press any key to reboot..."

The above scenario is also true for PPM builds. They will only install to a hard drive partition using a PPM anyboot image.

comment:3 Changed 3 years ago by pulkomandy

After checking installer code, not allowing install from ISO is by design. Installing from an ISO (not mounted with the attribute overlay) would most likely fail, as it would lost all FS attributes.

Suggested change for the other problem: Installer should check for an haiku or haiku_loader package. If there is none on the source disk, then it should be removed from the acceptable sources (or shown but disabled, that makes it clear it is not possible to install from it).

comment:4 Changed 2 years ago by vidrep

Since CD ISO nightly images have been dropped in favour of anyboot images, point .2, comment:2 is no longer applicable.

Last edited 2 years ago by vidrep (previous) (diff)

comment:5 Changed 2 years ago by pulkomandy

So that leaves us with just this: it is not possible to install a pre-PM haiku using the installer from a current version. Do we really need to support that?

comment:6 in reply to:  5 Changed 2 years ago by vidrep

Replying to pulkomandy:

So that leaves us with just this: it is not possible to install a pre-PM haiku using the installer from a current version. Do we really need to support that?

Not unless we're planning on reverting package management.

Otherwise, your other comment above should probably be addressed somehow and documented:

'Suggested change for the other problem: Installer should check for an haiku or haiku_loader package. If there is none on the source disk, then it should be removed from the acceptable sources (or shown but disabled, that makes it clear it is not possible to install from it)."

comment:7 Changed 18 months ago by stippi

I stumbled across this problem today, because an older system wouldn't let me upgrade. It feels like an intuitive solution to download the newest image, mount it and try to install from it. Maybe mountvolumne should mount ISOs with the attribute layer by default. I mean, if there is no attribute information there, then there simply won't be any attributes, but mounting with the layer shouldn't be a problem, no?

The next thing I tried was to download a RAW image and mount that instead. However, I couldn't select the boot volume as the target, it was greyed out.

comment:8 Changed 15 months ago by vidrep

I've been installing Haiku to HDD partitions from mounted RAW images for the past month without any issue. This is probably how it was done in BeOS. We should document this feature somewhere, taking care to make the distinction between anyboot and RAW images. I think this issue can be closed. Any further comment?

comment:9 Changed 15 months ago by pulkomandy

Resolution: no change required
Status: newclosed

The anyboot image should work for this as well, if you mount it properly (diskimage register ...).

So, I think it is safe to close this now. This is a power-user feature and it is acceptable that one has to be careful about the type of image used.

Note: See TracTickets for help on using tickets.