Opened 12 years ago

Closed 6 years ago

#1319 closed bug (no change required)

[Tracker] desktop icons selection is shifted 1px to the left

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc: aldeck, olive@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

To see it open Magnify resize it a little bit and select Haiku volume on desktop. I will attach screenshot. Don't know ehich component to select for this bug, so please assign it.

Attachments (1)

shot.png (59.6 KB ) - added by diver 12 years ago.

Download all attachments as: .zip

Change History (17)

by diver, 12 years ago

Attachment: shot.png added

comment:1 by diver, 12 years ago

Component: - GeneralKits/Interface Kit
Summary: [Tracker] desktop icons selection is 1px to the left[Tracker] desktop icons selection is shifted 1px to the left

comment:2 by jackburton, 12 years ago

How does it look on R5 ?

comment:3 by diver, 12 years ago

It's not shifted.

comment:4 by stippi, 12 years ago

No it is shifted on R5, but not as much as on Haiku. I vote for changing whatever we need to change so it is indeed not shifted at all.

in reply to:  4 comment:5 by jackburton, 12 years ago

Replying to stippi:

No it is shifted on R5, but not as much as on Haiku. I vote for changing whatever we need to change so it is indeed not shifted at all.

Of course, I didn't mean: "if it's shifted on R5, let's keep it shifted", I was just looking for an hint for where to look: i.e. Tracker or our libbe :)

comment:6 by jackburton, 12 years ago

I suspect haiku renders the text 1 pixels off to the right in respect to how it's rendered on beos. Evidences:

  • The problem described here
  • this comment in BTextView::PointAt()

convert from text rect coordinates NOTE: I didn't understand why "- 1.0" and it works only correct without it on Haiku app_server. Feel free to enlighten me though! result.x += fTextRect.left; - 1.0;

  • The fact that our Terminal on BeOS draws the text 1 pixel shifted to the left

comment:7 by aldeck, 11 years ago

Cc: aldeck added

comment:8 by jackburton, 11 years ago

I had a look at this. Removing the + 1 in the following code:

BPoint loc; loc.y = textRect.bottom - view->FontInfo().descent; loc.x = textRect.left + 1;

in TextWidget.cpp, BTextWidget::Draw(), fixes the problem. But again, since the selection isn't as shifted in beos as it is on haiku, I think the problem could be more what I wrote in comment 6.

comment:9 by karmak, 11 years ago

Cc: olive@… added

comment:10 by diver, 10 years ago

Still here in hrev35569.

comment:11 by diver, 10 years ago

Version: R1/pre-alpha1R1/Development

comment:12 by x-ist, 9 years ago

Don't know if it helps but this does not happen when "List view" mode is chosen.

comment:13 by diver, 9 years ago

As it seems to be a bug in BTextView, maybe zooey could have a look? :-)

in reply to:  13 comment:14 by jackburton, 9 years ago

Replying to diver:

As it seems to be a bug in BTextView, maybe zooey could have a look? :-)

It's not. Tracker uses BTextView only in edit mode, not for just displaying the text.

comment:15 by diver, 9 years ago

Damn it! :-) Anyway it's still reproducible in hrev38300.

comment:16 by stippi, 6 years ago

Resolution: no change required
Status: newclosed

I've looked into it and this is now a won't-fix for me. See hrev46903.

Note: See TracTickets for help on using tickets.