Opened 12 years ago

Closed 11 years ago

#1327 closed bug (fixed)

Media addon not always loaded when running in vmplayer

Reported by: emitrax Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc: mmu_man
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When I run Haiku with vmplayer and boot with my usb webcam attached, the usb_webcam.media_addon is loaded randomly. I also tried to plug it during the boot but the result is the same. On real hardware though, it is always loaded. I don't know if this is either a media bug or a usb one.

Attachments (1)

media.jpg (17.0 KB ) - added by emitrax 11 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 by marcusoverhagen, 12 years ago

attach output of:

ls -R -l /dev/bus/usb

for both cases (detected, not detected)

comment:2 by emitrax, 12 years ago

-- Detected -- ~>ls -l -R /dev/bus/usb/ /dev/bus/usb/: total 0 drwxr-xr-x 1 baron users 0 2007-07-24 21:59 0 crw-r--r-- 1 baron users 0 2007-07-24 21:59 raw

/dev/bus/usb/0: total 0 crw-r--r-- 1 baron users 0 2007-07-24 21:59 0 crw-r--r-- 1 baron users 0 2007-07-24 21:59 hub

-- NOT detected -- ~>ls -l -R /dev/bus/usb/ /dev/bus/usb/: total 0 drwxr-xr-x 1 baron users 0 2007-07-24 21:56 0 crw-r--r-- 1 baron users 0 2007-07-24 21:56 raw

/dev/bus/usb/0: total 0 crw-r--r-- 1 baron users 0 2007-07-24 21:56 hub

Looks like an USB bug since the 0 entry is missing when not detected.

comment:3 by marcusoverhagen, 12 years ago

Cc: mmu_man added
Component: Add-OnsDrivers/USB
Owner: changed from marcusoverhagen to mmlr

reassigning to someone who might know how to help :)

comment:4 by mmlr, 11 years ago

Status: newassigned

Is this still reproducible? If so could you add a serial log with USB tracing enabled? There will probably be relevant information like not able to address the device or failing to configure etc.

comment:5 by emitrax, 11 years ago

Unfortunately I don't have my webcam here with me. Can't test it until July.

by emitrax, 11 years ago

Attachment: media.jpg added

comment:6 by emitrax, 11 years ago

I booted a couple of times and problem seems to be gone.

However, the media server does not unload the add when unplugging the webcam, neither to it loaded if load the webcam while the system is up and running. I need to restart the media server to let it rescan for new devices. Plus, as shown in the picture attached, some drawn problems seems to have raised.

Shall I open a different ticket for loading/unloading addons ?

comment:7 by mmlr, 11 years ago

Resolution: fixed
Status: assignedclosed

I would prefer if you could open a bug or enhancement for the load/unload. Probably the media server or the respective add-on does not yet employ node-monitoring to detect the device change. Closing this ticket as the original problem (the device not being published) seems gone. Thanks for the update.

Note: See TracTickets for help on using tickets.