Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1328 closed bug (fixed)

devices emuxki and auich don't survive a media services restart

Reported by: jonas.kirilla Owned by: korli
Priority: normal Milestone: R1
Component: Servers/media_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Neither of my audio devices (the integrated auich and the emuxki) remain in the Media Preferences after having restarted the services. Both work, AFAIK. MediaPlayer can play through both. (I had to remove the drivers of the default, emuxki, to verify that the auich too works.)

This is with hrev21691 (and lots of previous revisions) on real hardware. See attached files.

(I've also mentioned this briefly in #1323 (unhandled interrupts), but I have not been able to find any correlation between unhandled emuxki interrupts and the media services losing control of these devices.)

Attachments (15)

normal boot with emuxki and auich, r21691 (54.5 KB) - added by jonas.kirilla 12 years ago.
Media prefs stdout in Terminal when restarting media server (5.0 KB) - added by jonas.kirilla 12 years ago.
cat device returns error, ls -R dev (1.8 KB) - added by jonas.kirilla 12 years ago.
listdev (2.2 KB) - added by jonas.kirilla 12 years ago.
screen1.png (53.3 KB) - added by jonas.kirilla 12 years ago.
screen2.png (35.1 KB) - added by jonas.kirilla 12 years ago.
screen3.png (35.3 KB) - added by jonas.kirilla 12 years ago.
screen4.png (50.9 KB) - added by jonas.kirilla 12 years ago.
screen5.png (48.2 KB) - added by jonas.kirilla 12 years ago.
screen6.png (29.8 KB) - added by jonas.kirilla 12 years ago.
normal boot, r21696 (54.5 KB) - added by jonas.kirilla 12 years ago.
stdout in Terminal from Media prefs during restart of media services (8.9 KB) - added by jonas.kirilla 12 years ago.
serial output during restarting media services (3.2 KB) - added by jonas.kirilla 12 years ago.
gdb debug output for media addon server (2.3 KB) - added by jonas.kirilla 12 years ago.
strange media server silent segfault (57.3 KB) - added by jonas.kirilla 12 years ago.

Download all attachments as: .zip

Change History (22)

Changed 12 years ago by jonas.kirilla

Changed 12 years ago by jonas.kirilla

Changed 12 years ago by jonas.kirilla

Attachment: listdev added

comment:1 Changed 12 years ago by marcusoverhagen

Owner: changed from marcusoverhagen to korli

comment:2 Changed 12 years ago by korli

Resolution: fixed
Status: newclosed

Should be fixed as of hrev21696

Changed 12 years ago by jonas.kirilla

Attachment: screen1.png added

Changed 12 years ago by jonas.kirilla

Attachment: screen2.png added

Changed 12 years ago by jonas.kirilla

Attachment: screen3.png added

Changed 12 years ago by jonas.kirilla

Attachment: screen4.png added

Changed 12 years ago by jonas.kirilla

Attachment: screen5.png added

Changed 12 years ago by jonas.kirilla

Attachment: screen6.png added

Changed 12 years ago by jonas.kirilla

Attachment: normal boot, r21696 added

Changed 12 years ago by jonas.kirilla

Changed 12 years ago by jonas.kirilla

Changed 12 years ago by jonas.kirilla

comment:3 Changed 12 years ago by jonas.kirilla

Both devices show up in the Media preferences now in hrev21696, post-restart. The drivers seem fine to me, from what I can tell from serial output. But the rest : the media kit, server, addon server, preferences and the MediaPlayer all seems very fragile. See attached files and further comments.

(The screenshots and texts are not directly related. IIRC, emuxki is missing from the shots because I removed the driver temporarily to test restarting the media services with only auich. Both drivers are there in the serial/stdout/debuger capture when the media addon server crashes.)

(I don't think audio works after restarting the media services. It's not possible to choose auich - it always falls back to emuxki. When the audio works MediaPlayer leaves sliders behind in the mixer, after having been quit. Often MediaPlayer gets stuck on a playing a track.)

Please advise how to continue, if you see fit.

comment:4 Changed 12 years ago by korli

Jonas I agree with the stability problem. Typically some errors are exposed in Haiku which are not observed in BeOS. Handling correctly such errors is one thing we should fix. But errors could also originate from lower layers (libbe, kernel) :) So could you make some unit tests to identify bugs and then make new reports ?

comment:5 Changed 12 years ago by korli

I could reproduce the "gdb debug output for media addon server" and indeed a check is missing in multi_audio media addon. Though it's not the original problem (which could reside in audio drivers).

comment:6 Changed 12 years ago by marcusoverhagen

This whole blob of images and debug output doesn't help at all.

I'm not going investigate this mess further.

Appereantly you found a least a single bug in the hmulti_audio-addon WriteZeros function. Please file a separate bug report for this if you want to help us. Please do not reopen this ticket.

comment:7 Changed 12 years ago by korli

The segfault in WriteZeros() should be fixed in hrev21758. It actually shows a problem in the driver. So it would greatly help if you can test each audio driver one after the other and open new bugs. Thanks.

Note: See TracTickets for help on using tickets.