Opened 2 years ago

Closed 9 months ago

#13371 closed bug (fixed)

Tracker crash in BPrivate::BPoseView::AddPosesTask

Reported by: Duggan Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Applications/Tracker Version: R1/Development
Keywords: tracker Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Using Paladin, I tried double clicking the .rsrc file which Tracker complained it had no program to open. I clicked find. I closed the resulting window. Tracker crashed. Highly repeatable. Does not occur if the query completes before closing, but does occur whether you close the window via the close button on the tab or the cancel button. Tried opening from Tracker (not using Paladin), crash still occurred. Tried opening another unknown file type, crash still occurred.

Running x86_64 hrev50867

Debugger crash report attached.

Attachments (3)

Tracker-156112-debug-10-03-2017-23-43-01.report (62.7 KB) - added by Duggan 2 years ago.
Tracker-4929-debug-11-03-2017-07-37-31.report (25.9 KB) - added by humdinger 2 years ago.
gcc2hybrid crash
intercal.ps (249.0 KB) - added by humdinger 2 years ago.
untyped file for testing

Download all attachments as: .zip

Change History (12)

comment:3 Changed 2 years ago by humdinger

I can confirm on gcc2hybrid, hrev50997. Attached the crash report. Also attached a file to test with, as it needs to be an "unsniffable" file as the query is otherwise to quickly finished to be interrupted. You gotta be quick...

Changed 2 years ago by humdinger

gcc2hybrid crash

Changed 2 years ago by humdinger

Attachment: intercal.ps added

untyped file for testing

comment:6 Changed 2 years ago by diver

Component: - GeneralApplications/Tracker
Owner: changed from nobody to axeld
Platform: x86-64All

comment:7 Changed 2 years ago by waddlesplash

From the stack trace, looks like a double free?

comment:8 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:9 Changed 2 years ago by waddlesplash

I started working on cleaning up Tracker's threads properly (first cause of this bug): https://github.com/waddlesplash/haiku/tree/tracker_cleanup_threads_properly -- but I ran into a really nasty double free in the exception handler for failToLock that I don't really know what the cause is. Needs more investigation.

comment:11 Changed 12 months ago by diver

Still here in hrev52014.

comment:12 Changed 12 months ago by diver

Summary: Tracker crashTracker crash in BPrivate::BPoseView::AddPosesTask

comment:13 Changed 9 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Fixed in hrev52350.

Note: See TracTickets for help on using tickets.