Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#1343 closed bug (fixed)

Corrupted characters show up when saving a People file

Reported by: karma Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If the /boot/home/people folder doesn't exist, the People file's default name is corrupted.

When the dialog is closed, and Save is invoked again, it works fine (the folder was created during the first try). It also works if the People application or the whole OS is restarted.

See attached picture for reference.


To reproduce:

  • Make sure the /boot/home/people directory doesn't exist, and People isn't running.
  • Start People.
  • Enter a name.
  • Select File -> Save.

Attachments (1)

People bug when saving.png (25.6 KB) - added by karma 12 years ago.
Screenshot

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by karma

Attachment: People bug when saving.png added

Screenshot

comment:1 Changed 11 years ago by modeenf

Couldn't reproduce it in hrev23050 (was running Haiku from vmware)

comment:2 Changed 11 years ago by jackburton

Resolution: fixed
Status: newclosed

Was fixed in the meantime.

comment:3 Changed 11 years ago by jackburton

Component: - Applications/PeopleServers/app_server
Note: See TracTickets for help on using tickets.