Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#13578 closed enhancement (invalid)

repair old generic IDE code

Reported by: Alexco Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Disk Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

I know that the old IDE stack will be removed sooner or later (more sooner I guess), but in my opinion it should be removed in a state where you can compile and use it. For some debugging reasons I needed the old stack and so I can provide some small patches for that.

Attachments (3)

patch1.diff (493 bytes ) - added by Alexco 2 years ago.
patch2.diff (3.3 KB ) - added by Alexco 2 years ago.
patch3.diff (432 bytes ) - added by Alexco 2 years ago.

Download all attachments as: .zip

Change History (10)

by Alexco, 2 years ago

Attachment: patch1.diff added

comment:1 by Alexco, 2 years ago

Has a Patch: set

by Alexco, 2 years ago

Attachment: patch2.diff added

by Alexco, 2 years ago

Attachment: patch3.diff added

comment:2 by diver, 2 years ago

IDE stack was removed a few days ago. Perhaps a better idea would be to move it to HaikuArchives and create a recipe for it?

comment:3 by waddlesplash, 2 years ago

It's my understanding that the ATA stack and the IDE stack cannot be included in the image at the same time, so having it at HaikuArchives would not help here.

What reason did you need it for testing? Is there some deficiency in the ATA stack?

comment:4 by Alexco, 2 years ago

Okay, it seems I am too late :-(. It is also my understanding that ATA and IDE stack exclude each other. Otherwise there would be no sense in switching the stacks with a build rule.

My understanding is that there are a lot of issues with the ATA stack reported. I also reported https://dev.haiku-os.org/ticket/12292 which is the reason I tried to build IDE stack (in fact Axel hinted that the IDE stack could be more robust than the ATA stack). But the issue is also present with IDE stack. So I decided to submit the small patches and concentrate on finding the issue in ATA stack.

comment:5 by waddlesplash, 2 years ago

Resolution: invalid
Status: newclosed

Well, if the IDE stack had the same issue, there's no sense in trying to resurrect it :)

Yes, if you know your way around the ATA stack enough to try to fix it, please do. And don't hesitate to ask questions.

comment:6 by Alexco, 2 years ago

It was not my intention to resurrect it, just to fix the build process before it got removed, so it would be at least in a consistent state :-).

comment:7 by pulkomandy, 2 years ago

Well, the main reason there are lots of bugs against the new ATA stack is that it gets used by people. The old IDE one was unused for a very long time now, and I'd say it is likely to have *more* problems by now. I'm not even sure it can work with SATA/AHCI drives, which would make it unusable on most modern systems. It probably won't work in 64bit, either.

It's better to let this old code go away and focus on the new stack.

Note: See TracTickets for help on using tickets.