Opened 21 months ago

Last modified 5 weeks ago

#13846 new task

AMD RX Vega Series

Reported by: Karan Owned by: kallisti5
Priority: normal Milestone: Unscheduled
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #14955, #14956
Has a Patch: no Platform: All

Description

Haiku does not support AMD RX Vega Series.

Attachments (2)

20180909_230854.jpg (2.0 MB) - added by cb88 12 months ago.
Vega FE accelerant crash at boot works with accelerant disabled in boot menu on x370 Mobo + ryzen 1700x
smlnjoe_Vega11_syslog (203.8 KB) - added by smlnjoe 5 weeks ago.

Change History (16)

comment:1 Changed 21 months ago by Karan

Has a Patch: set

comment:2 Changed 21 months ago by Karan

Model (Codename) Launch Architecture (Fab) Transistors Die Size Core Fillrate[a][b][c] Processing power[a][d] (GFLOPS) Memory TBP (W) Bus interface Release Price (USD) Config[e] Clock[a] (MHz) Texture (GT/s) Pixel (GP/s) Half Single Double Bus type & width Size (GiB) Clock (MT/s) Band- width (GB/s) Radeon RX Vega 56[12][13][14] August 28, 2017 GCN 5th gen (14 nm) 12.5×109 486 mm2 3584:224:64 1156 1471 258.9 329.5 74.0 94.1 16572 21088 8286 10544 518 659 HBM2 2048-bit 8 1600 410 210 PCIe 3.0 ×16 $399 Radeon RX Vega 64[12][14][15] August 14, 2017 4096:256:64 1247 1546 319.2 395.8 79.8 98.9 20431 25330 10215 12665 638 792 1890 483.8 295 $499 Radeon RX Vega 64 Liquid[12][14][15] 1406 1677 359.9 429.3 90.0 107.3 23036 27476 11518 13738 720 859 345 $699

comment:3 Changed 21 months ago by kallisti5

We might be able to easily, but will need a copy of /var/log/syslog from Haiku running on the system with the Vega card installed.

comment:4 Changed 19 months ago by pulkomandy

Has a Patch: unset

comment:5 Changed 16 months ago by cocobean

Please add this revision to radeon_hd kernel driver: https://git.haiku-os.org/haiku/tree/src/add-ons/kernel/drivers/graphics/radeon_hd/driver.cpp

        // Introduced: 2017
	// Codename: Vega
	// Process: 14nm
	{0x15dd, 13, 0, RADEON_VEGA, CHIP_STD, "Radeon RX Vega Mobility"},
	{0x15ff, 13, 0, RADEON_VEGA, CHIP_STD, "Radeon RX Vega Mobility"},
	{0x6861, 13, 0, RADEON_VEGA, CHIP_STD, "Radeon PRO WX 9100"},
	{0x6863, 13, 0, RADEON_VEGA, CHIP_STD, "Radeon Vega Frontier Edition"},
	{0x6867, 13, 0, RADEON_VEGA, CHIP_STD, "Radeon RX Vega 56"},
	{0x687F, 13, 0, RADEON_VEGA, CHIP_STD, "Radeon RX Vega 64"},
	{0x684c, 13, 0, RADEON_VEGA, CHIP_STD, "Radeon RX Vega M GH"},
	{0x684e, 13, 0, RADEON_VEGA, CHIP_STD, "Radeon RX Vega M GL"}
Last edited 16 months ago by cocobean (previous) (diff)

comment:6 Changed 16 months ago by kallisti5

Were any of these tested working for you?

comment:7 Changed 16 months ago by cocobean

Last edited 14 months ago by cocobean (previous) (diff)

comment:8 Changed 13 months ago by kallisti5

PCIID's added in hrev52110. Please test and let me know of any cards that don't work at all.

Changed 12 months ago by cb88

Attachment: 20180909_230854.jpg added

Vega FE accelerant crash at boot works with accelerant disabled in boot menu on x370 Mobo + ryzen 1700x

comment:9 Changed 12 months ago by cb88

I have mobile Vega 8 also but it doesn't boot with 4gb limit enabled so can't test it yet... Probably there is a conflict between disabling the ram and where the vram is allocated?

comment:10 Changed 5 months ago by cb88

Blocking: 14955 added

comment:11 Changed 5 months ago by cb88

Blocking: 14956 added

comment:12 Changed 5 weeks ago by cocobean

Thanks, kallisti5 for adding the Vega support to the driver. I did note a missing 'Vega' chip name label entry in the code for radeon_chipset RADEON_VEGA:

headers/private/graphics/radeon_hd/radeon_hd.h
radeon_chip_name

It booted to rocket icon on splash screen and I could go into the Haiku boot menu. Check with Karan, but it got that far for me. (7/17/2019 - went to a compatible gfx card)

comment:13 Changed 5 weeks ago by cb88

I'm not sure I follow did you bypass blacklisting of Vega for this driver or run it with the fallback driver?

Are you sure you booted using the radeon_hd driver IIRC Vega and some Polaris are blacklisted, or enabled but just don't work (Vega FE last I checked)... note I think the driver doesn't really kick in until just before switching to the desktop so the boot screen doesn't really count (some devices this will cause a black or white screen temporarily).

Also just FYI nothing has been done in the driver since I last tested on Vega FE. I suppose it is possible something else got fixed though.

Changed 5 weeks ago by smlnjoe

Attachment: smlnjoe_Vega11_syslog added

comment:14 Changed 5 weeks ago by smlnjoe

Added Syslog (smlnjoe_Vega11_syslog) for Ryzen 5 2400G APU. Using the built in Vega 11 it looks like the Atom Bios is not found and the driver does not load. Nightly 64 bit hrev 53237

Note: See TracTickets for help on using tickets.