Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#13861 closed bug (fixed)

KDL: ps2 service

Reported by: vidrep Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers Version: R1/Development
Keywords: PS2 Cc: axeld
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev51669 x86_64

Ran pkgman update-> hrev51669 to 51670

After rebooting KDL

Photo of KDL and relevant part of syslog attached

Attachments (2)

IMG_0020.JPG (1015.0 KB) - added by vidrep 19 months ago.
syslog_ps2 (567 bytes) - added by vidrep 19 months ago.

Download all attachments as: .zip

Change History (8)

Changed 19 months ago by vidrep

Attachment: IMG_0020.JPG added

Changed 19 months ago by vidrep

Attachment: syslog_ps2 added

comment:1 Changed 19 months ago by waddlesplash

Component: - GeneralDrivers
Keywords: PS2 added

comment:2 Changed 19 months ago by waddlesplash

Cc: axeld added

http://xref.plausible.coop/source/xref/haiku/src/system/kernel/fs/vfs.cpp#1931

It seems context was NULL here and thus the KDL. Would adding a NULL check there be OK?

comment:3 Changed 19 months ago by waddlesplash

Proposed fix at https://github.com/waddlesplash/haiku/commit/27d0cc38670d42eac2aa7b0112eb5d6d4a382cd7, but as I know little about the code I will not commit it until someone with more knowledge of these subsystems can review.

comment:4 Changed 19 months ago by waddlesplash

Resolution: fixed
Status: newclosed

Fixed in hrev51692.

comment:5 Changed 19 months ago by vidrep

I believe this was a duplicate of one if my other tickets. Hopefully it is fixed for real, as it has been an issue for a very long time. https://dev.haiku-os.org/ticket/11439

comment:6 Changed 19 months ago by waddlesplash

Yep, this fix should resolve that problem too.

Note: See TracTickets for help on using tickets.