Opened 2 years ago

Last modified 10 months ago

#13936 reopened bug

PC does not shutdown after system update.

Reported by: khallebal Owned by: tqh
Priority: normal Milestone:
Component: Drivers/ACPI Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #13938
Has a Patch: no Platform: x86

Description

After i updated to hrev51727 the OS goes all the way down the screen goes black but the fans keep turning, never experienced this before. Attaching the syslog.

Attachments (2)

syslog (512.0 KB ) - added by khallebal 2 years ago.
syslog.2 (341.0 KB ) - added by roiredxsoto 17 months ago.

Download all attachments as: .zip

Change History (30)

by khallebal, 2 years ago

Attachment: syslog added

comment:1 by khallebal, 2 years ago

Sorry forgot to mention the hrev i updated from, it's hrev51716, the regression is probably related to the APM driver and not the ACPI one, it's just that it's the closest option i could get from the trac.

comment:2 by korli, 2 years ago

the APM driver wasn't modified in this range, the ACPI one was modified in this range.

comment:3 by tqh, 2 years ago

From syslog it seems likely to that something else is hanging the shutdown, looks like it could be whatever writes

KERN: check_sense: encountered DEFERRED ERROR - bye, bye

Did it shutdown before this revision? Do you have ACPI enabled? Do you have APM enabled? What hardware is this on?

comment:4 by un_spacyar, 2 years ago

I found a similar issue in my laptop. After update to hrev51727 (x86_gcc2), the system shows the window "is now safe to turn off the computer", instead of the automatic power-off.

In the syslog I found the following:

ACPI Exception: AE_BAD_PARAMETER, Returned by Handler for [EmbeddedControl] (20170303/evregion-425)
ACPI Error: Method parse/execution failed [\_PTS] (Node 0x82a28e30), AE_BAD_PARAMETER (20170303/psparse-668)

The listdev output is the following:

device Signal processing controller [11|80|0]
  vendor 8086: Intel Corporation
  device 2932: 82801I (ICH9 Family) Thermal Subsystem

device Serial bus controller (SMBus) [c|5|0]
  vendor 8086: Intel Corporation
  device 2930: 82801I (ICH9 Family) SMBus Controller

device Mass storage controller (SATA controller, AHCI 1.0) [1|6|1]
  vendor 8086: Intel Corporation
  device 2929: 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode]

device Bridge (ISA bridge) [6|1|0]
  vendor 8086: Intel Corporation
  device 2919: ICH9M LPC Interface Controller

device Bridge (PCI bridge, Subtractive decode) [6|4|1]
  vendor 8086: Intel Corporation
  device 2448: 82801 Mobile PCI Bridge

device Serial bus controller (USB controller, EHCI) [c|3|20]
  vendor 8086: Intel Corporation
  device 293a: 82801I (ICH9 Family) USB2 EHCI Controller #1

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2936: 82801I (ICH9 Family) USB UHCI Controller #3

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2935: 82801I (ICH9 Family) USB UHCI Controller #2

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2934: 82801I (ICH9 Family) USB UHCI Controller #1

device Network controller (Ethernet controller) [2|0|0]
  vendor 168c: Qualcomm Atheros
  device 001c: AR242x / AR542x Wireless Network Adapter (PCI-Express)

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 8086: Intel Corporation
  device 2942: 82801I (ICH9 Family) PCI Express Port 2

device Network controller (Ethernet controller) [2|0|0]
  vendor 10ec: Realtek Semiconductor Co., Ltd.
  device 8136: RTL8101/2/6E PCI Express Fast Ethernet controller

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 8086: Intel Corporation
  device 2940: 82801I (ICH9 Family) PCI Express Port 1

device Multimedia controller (Audio device) [4|3|0]
  vendor 8086: Intel Corporation
  device 293e: 82801I (ICH9 Family) HD Audio Controller

device Serial bus controller (USB controller, EHCI) [c|3|20]
  vendor 8086: Intel Corporation
  device 293c: 82801I (ICH9 Family) USB2 EHCI Controller #2

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2939: 82801I (ICH9 Family) USB UHCI Controller #6

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2938: 82801I (ICH9 Family) USB UHCI Controller #5

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2937: 82801I (ICH9 Family) USB UHCI Controller #4

device Display controller [3|80|0]
  vendor 8086: Intel Corporation
  device 2a43: Mobile 4 Series Chipset Integrated Graphics Controller

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
  vendor 8086: Intel Corporation
  device 2a42: Mobile 4 Series Chipset Integrated Graphics Controller

device Bridge (Host bridge) [6|0|0]
  vendor 8086: Intel Corporation
  device 2a40: Mobile 4 Series Chipset Memory Controller Hub
~>

Not sure about the ACPI / APM configuration. This notebook had a very limited BIOS information.

Please, tell me if you prefeer a new ticket, if you found this is not related to the same issue.

comment:5 by diver, 2 years ago

Blocking: 13938 added

in reply to:  3 comment:6 by khallebal, 2 years ago

Replying to Fredrik Holmqvist:

From syslog it seems likely to that something else is hanging the shutdown, looks like it could be whatever writes

KERN: check_sense: encountered DEFERRED ERROR - bye, bye

Did it shutdown before this revision? Do you have ACPI enabled? Do you have APM enabled? What hardware is this on?

As i said in the first comment i've never experienced this before, i've always used this pc with the defaults(i.e ACPI on APM off), it used to shutdown properly before this revision.

This is my HW:

device Network controller (Ethernet controller) [2|0|0]
  vendor 1106: VIA Technologies, Inc.
  device 3065: VT6102/VT6103 [Rhine-II]

device Multimedia controller (Multimedia audio controller) [4|1|0]
  vendor 1106: VIA Technologies, Inc.
  device 3059: VT8233/A/8235/8237 AC97 Audio Controller

device Bridge (ISA bridge) [6|1|0]
  vendor 1106: VIA Technologies, Inc.
  device 3227: VT8237 ISA bridge [KT600/K8T800/K8T890 South]

device Serial bus controller (USB controller, EHCI) [c|3|20]
  vendor 1106: VIA Technologies, Inc.
  device 3104: USB 2.0

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 1106: VIA Technologies, Inc.
  device 3038: VT82xx/62xx UHCI USB 1.1 Controller

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 1106: VIA Technologies, Inc.
  device 3038: VT82xx/62xx UHCI USB 1.1 Controller

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 1106: VIA Technologies, Inc.
  device 3038: VT82xx/62xx UHCI USB 1.1 Controller

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 1106: VIA Technologies, Inc.
  device 3038: VT82xx/62xx UHCI USB 1.1 Controller

device Mass storage controller (IDE interface) [1|1|8a]
  vendor 1106: VIA Technologies, Inc.
  device 0571: VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE

device Mass storage controller (IDE interface) [1|1|8f]
  vendor 1106: VIA Technologies, Inc.
  device 3149: VIA VT6420 SATA RAID Controller

device Network controller (Ethernet controller) [2|0|0]
  vendor 168c: Qualcomm Atheros
  device 0013: AR5212/5213/2414 Wireless Network Adapter

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
  vendor 1106: VIA Technologies, Inc.
  device 3344: CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro]

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 1106: VIA Technologies, Inc.
  device b198: VT8237/VX700 PCI Bridge

device Bridge (Host bridge) [6|0|0]
  vendor 1106: VIA Technologies, Inc.
  device 7314: CN700/VN800/P4M800CE/Pro Host Bridge

device Bridge (Host bridge) [6|0|0]
  vendor 1106: VIA Technologies, Inc.
  device 4314: CN700/VN800/P4M800CE/Pro Host Bridge

device Bridge (Host bridge) [6|0|0]
  vendor 1106: VIA Technologies, Inc.
  device 3208: PT890 Host Bridge

device Bridge (Host bridge) [6|0|0]
  vendor 1106: VIA Technologies, Inc.
  device 2314: CN700/VN800/P4M800CE/Pro Host Bridge

device Bridge (Host bridge) [6|0|0]
  vendor 1106: VIA Technologies, Inc.
  device 1314: CN700/VN800/P4M800CE/Pro Host Bridge

device Bridge (Host bridge) [6|0|0]
  vendor 1106: VIA Technologies, Inc.
  device 0314: CN700/VN800/P4M800CE/Pro Host Bridge.

@korli, sorry you right i didn't notice that the ACPI driver has had modifications in this range.

Last edited 2 years ago by khallebal (previous) (diff)

comment:7 by tqh, 23 months ago

This will probably be solved by fixing #13929. Please don't duplicate this issue yet though.

comment:8 by tqh, 23 months ago

Resolution: fixed
Status: newclosed

Should be fixed in hrev51771.

in reply to:  8 comment:9 by khallebal, 23 months ago

Replying to Fredrik Holmqvist:

Should be fixed in hrev51771.

Unforttunatly it's not, i did a clean install with hrev51775 and the situation remains unchanged.

comment:10 by khallebal, 23 months ago

Resolution: fixed
Status: closedreopened

comment:11 by bbjimmy, 22 months ago

on my eeepc hrev51791 system shutsdown and powers off if I press the power button, but if I select "Shutdown - Power off" from the Deskbar menu, Haiku shuts down, but the power remains on.

comment:12 by khallebal, 22 months ago

I'm using hrev51791 right now, and i've had such behaviour too, but it's never reproducible 100%, i had times where pressing the power button works, and the next time it doesn't, i tried disabling my wifi, same somtimes it works other times it doesn't, i can't find a 100% reproducible pattern, so maybe we should just skip this revision and go back to the one that worked, and wait for the next revision which may not introduce regressions like this one, there are at least 3 new bugs introduced with this new revision.

comment:13 by tqh, 22 months ago

Sorry, but there isn't a solution that works for all and before it was kind of broken for the normal case (newer machines) and working in special cases (Via, Eee). I rather have most cases working and introduce special fixes for old and/or novel hardware. Please report what hardware you use so I can undrrstand how to fix this best.

in reply to:  13 comment:14 by khallebal, 22 months ago

Replying to Fredrik Holmqvist:

Sorry, but there isn't a solution that works for all and before it was kind of broken for the normal case (newer machines) and working in special cases (Via, Eee). I rather have most cases working and introduce special fixes for old and/or novel hardware. Please report what hardware you use so I can undrrstand how to fix this best.

Ok, i don't mind either way,i have already submitted the output of listdev in comment:6, if you need more specific details please let me know.

comment:15 by tqh, 22 months ago

I'm glad that you understand how complicated this is. I am not sure if it is smart to add logic for these cases or have it as a configuration flag, so it is good if as many as possible with problems in recent revisions report in with their hardware. From there I need to figure out if it really is the ACPI shutdown or a badly written driver or app that is the real problem. Much of the shutdown problem is really some hard intercpu communication problem that I have to work around so if someone could help on that it might be easier.

comment:16 by smashIt, 22 months ago

@ Fredrik: I updated to hrev51792 and power down works again on my Thinkpad T420. THX

comment:17 by bruno, 21 months ago

I had problems too... since years.. maybe the new patch works now!? #3811 helped me with my hp laptop to close...

comment:18 by waddlesplash, 19 months ago

Milestone: R1/beta1

Most of the shutdown issues have been resolved; moving out of beta1 milestone.

in reply to:  15 comment:19 by -Meanwhile-, 18 months ago

Replying to Fredrik Holmqvist:

[...] I am not sure if it is smart to add logic for these cases or have it as a configuration flag, so it is good if as many as possible with problems in recent revisions report in with their hardware.[...]

I have this shutdown issue on my Asus Eee Pc 901 in hrev52044.

by roiredxsoto, 17 months ago

Attachment: syslog.2 added

comment:20 by roiredxsoto, 17 months ago

Has a Patch: set

comment:21 by roiredxsoto, 17 months ago

Hello there,

I have the same issue on a Sony VGN-SR19XN, Bare Metal, Single boot (2 partitions: System and Data) with Haiku.

Actual Behaviour: Clicking on the "Power off" option in the Haiku menu shuts down all running processes, then mouse pointer stays locked with the "shutdown" window on the blue background. Need to force hardware shutdown. It does not matter how many apps are open. It happens with apps open, or with no app running.

Expected Behaviour: Clicking on the "Power off" option in the Haiku menu shuts down the computer properly.

 uname -a
Haiku shredder 1 hrev52140 Jul 30 2018 23:00:06 x86_64 x86_64 Haiku
~> listdev

device Serial bus controller (SMBus) [c|5|0]
  vendor 8086: Intel Corporation
  device 2930: 82801I (ICH9 Family) SMBus Controller

device Mass storage controller (SATA controller, AHCI 1.0) [1|6|1]
  vendor 8086: Intel Corporation
  device 2929: 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode]

device Bridge (ISA bridge) [6|1|0]
  vendor 8086: Intel Corporation
  device 2919: ICH9M LPC Interface Controller

device Generic system peripheral [8|80|0]
  vendor 1180: Ricoh Co Ltd
  device 0592: R5C592 Memory Stick Bus Host Adapter

device Generic system peripheral (SD Host controller) [8|5|0]
  vendor 1180: Ricoh Co Ltd
  device 0822: R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter

device Serial bus controller (FireWire (IEEE 1394), OHCI) [c|0|10]
  vendor 1180: Ricoh Co Ltd
  device 0832: R5C832 IEEE 1394 Controller

device Bridge (PCI bridge, Subtractive decode) [6|4|1]
  vendor 8086: Intel Corporation
  device 2448: 82801 Mobile PCI Bridge

device Serial bus controller (USB controller, EHCI) [c|3|20]
  vendor 8086: Intel Corporation
  device 293a: 82801I (ICH9 Family) USB2 EHCI Controller #1

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2939: 82801I (ICH9 Family) USB UHCI Controller #6

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2936: 82801I (ICH9 Family) USB UHCI Controller #3

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2935: 82801I (ICH9 Family) USB UHCI Controller #2

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2934: 82801I (ICH9 Family) USB UHCI Controller #1

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 8086: Intel Corporation
  device 2946: 82801I (ICH9 Family) PCI Express Port 4

device Network controller [2|80|0]
  vendor 8086: Intel Corporation
  device 4232: WiFi Link 5100

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 8086: Intel Corporation
  device 2944: 82801I (ICH9 Family) PCI Express Port 3

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 8086: Intel Corporation
  device 2942: 82801I (ICH9 Family) PCI Express Port 2

device Network controller (Ethernet controller) [2|0|0]
  vendor 11ab: Marvell Technology Group Ltd.
  device 4354: 88E8040 PCI-E Fast Ethernet Controller

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 8086: Intel Corporation
  device 2940: 82801I (ICH9 Family) PCI Express Port 1

device Multimedia controller (Audio device) [4|3|0]
  vendor 8086: Intel Corporation
  device 293e: 82801I (ICH9 Family) HD Audio Controller

device Serial bus controller (USB controller, EHCI) [c|3|20]
  vendor 8086: Intel Corporation
  device 293c: 82801I (ICH9 Family) USB2 EHCI Controller #2

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2938: 82801I (ICH9 Family) USB UHCI Controller #5

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2937: 82801I (ICH9 Family) USB UHCI Controller #4

device Display controller [3|80|0]
  vendor 8086: Intel Corporation
  device 2a43: Mobile 4 Series Chipset Integrated Graphics Controller

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
  vendor 8086: Intel Corporation
  device 2a42: Mobile 4 Series Chipset Integrated Graphics Controller

device Bridge (Host bridge) [6|0|0]
  vendor 8086: Intel Corporation
  device 2a40: Mobile 4 Series Chipset Memory Controller Hub
~> Jul 30 2018 23:00:06 x86_64 x86_64 Haiku
bash: Jul: command not found
~> ~> listdev
bash: /boot/home: Is a directory
~> 
~> device Serial bus controller (SMBus) [c|5|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2930: 82801I (ICH9 Family) SMBus Controller
bash: syntax error near unexpected token `('
~> 
~> device Mass storage controller (SATA controller, AHCI 1.0) [1|6|1]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2929: 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode]
bash: syntax error near unexpected token `('
~> 
~> device Bridge (ISA bridge) [6|1|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2919: ICH9M LPC Interface Controller
bash: device: command not found
~> 
~> device Generic system peripheral [8|80|0]
bash: device: command not found
bash: 80: command not found
bash: 0]: command not found
~>   vendor 1180: Ricoh Co Ltd
bash: vendor: command not found
~>   device 0592: R5C592 Memory Stick Bus Host Adapter
bash: device: command not found
~> 
~> device Generic system peripheral (SD Host controller) [8|5|0]
bash: syntax error near unexpected token `('
~>   vendor 1180: Ricoh Co Ltd
bash: vendor: command not found
~>   device 0822: R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
bash: device: command not found
~> 
~> device Serial bus controller (FireWire (IEEE 1394), OHCI) [c|0|10]
bash: syntax error near unexpected token `('
~>   vendor 1180: Ricoh Co Ltd
bash: vendor: command not found
~>   device 0832: R5C832 IEEE 1394 Controller
bash: device: command not found
~> 
~> device Bridge (PCI bridge, Subtractive decode) [6|4|1]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2448: 82801 Mobile PCI Bridge
bash: device: command not found
~> 
~> device Serial bus controller (USB controller, EHCI) [c|3|20]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 293a: 82801I (ICH9 Family) USB2 EHCI Controller #1
bash: syntax error near unexpected token `('
~> 
~> device Serial bus controller (USB controller, UHCI) [c|3|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2939: 82801I (ICH9 Family) USB UHCI Controller #6
bash: syntax error near unexpected token `('
~> 
~> device Serial bus controller (USB controller, UHCI) [c|3|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2936: 82801I (ICH9 Family) USB UHCI Controller #3
bash: syntax error near unexpected token `('
~> 
~> device Serial bus controller (USB controller, UHCI) [c|3|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2935: 82801I (ICH9 Family) USB UHCI Controller #2
bash: syntax error near unexpected token `('
~> 
~> device Serial bus controller (USB controller, UHCI) [c|3|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2934: 82801I (ICH9 Family) USB UHCI Controller #1
bash: syntax error near unexpected token `('
~> 
~> device Bridge (PCI bridge, Normal decode) [6|4|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2946: 82801I (ICH9 Family) PCI Express Port 4
bash: syntax error near unexpected token `('
~> 
~> device Network controller [2|80|0]
bash: device: command not found
bash: 0]: command not found
bash: 80: command not found
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 4232: WiFi Link 5100
bash: device: command not found
~> 
~> device Bridge (PCI bridge, Normal decode) [6|4|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2944: 82801I (ICH9 Family) PCI Express Port 3
bash: syntax error near unexpected token `('
~> 
~> device Bridge (PCI bridge, Normal decode) [6|4|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2942: 82801I (ICH9 Family) PCI Express Port 2
bash: syntax error near unexpected token `('
~> 
~> device Network controller (Ethernet controller) [2|0|0]
bash: syntax error near unexpected token `('
~>   vendor 11ab: Marvell Technology Group Ltd.
bash: vendor: command not found
~>   device 4354: 88E8040 PCI-E Fast Ethernet Controller
bash: device: command not found
~> 
~> device Bridge (PCI bridge, Normal decode) [6|4|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2940: 82801I (ICH9 Family) PCI Express Port 1
bash: syntax error near unexpected token `('
~> 
~> device Multimedia controller (Audio device) [4|3|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 293e: 82801I (ICH9 Family) HD Audio Controller
bash: syntax error near unexpected token `('
~> 
~> device Serial bus controller (USB controller, EHCI) [c|3|20]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 293c: 82801I (ICH9 Family) USB2 EHCI Controller #2
bash: syntax error near unexpected token `('
~> 
~> device Serial bus controller (USB controller, UHCI) [c|3|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2938: 82801I (ICH9 Family) USB UHCI Controller #5
bash: syntax error near unexpected token `('
~> 
~> device Serial bus controller (USB controller, UHCI) [c|3|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2937: 82801I (ICH9 Family) USB UHCI Controller #4
bash: syntax error near unexpected token `('
~> 
~> device Display controller [3|80|0]
bash: device: command not found
bash: 80: command not found
bash: 0]: command not found
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2a43: Mobile 4 Series Chipset Integrated Graphics Controller
bash: device: command not found
~> 
~> device Display controller (VGA compatible controller, VGA controller) [3|0|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2a42: Mobile 4 Series Chipset Integrated Graphics Controller
bash: device: command not found
~> 
~> device Bridge (Host bridge) [6|0|0]
bash: syntax error near unexpected token `('
~>   vendor 8086: Intel Corporation
bash: vendor: command not found
~>   device 2a40: Mobile 4 Series Chipset Memory Controller Hub
bash: device: command not found
~> listimage | grep drivers
   56 0xffffffff819f3000 0xffffffff819fa000     0          0 /boot/system/add-ons/kernel/drivers/disk/virtual/ram_disk
   68 0xffffffff81657000 0xffffffff81658000     0          0 /boot/system/add-ons/kernel/drivers/dev/zero
   70 0xffffffff819c0000 0xffffffff819ca000     0          0 /boot/system/add-ons/kernel/drivers/dev/tty
   71 0xffffffff81668000 0xffffffff81669000     0          0 /boot/system/add-ons/kernel/drivers/dev/null
   72 0xffffffff81930000 0xffffffff81931000     0          0 /boot/system/add-ons/kernel/drivers/dev/dprintf
   73 0xffffffff8168c000 0xffffffff8168e000     0          0 /boot/system/add-ons/kernel/drivers/dev/console
  348 0xffffffff81986000 0xffffffff81988000     0          0 /boot/system/add-ons/kernel/drivers/power/acpi_button
  363 0xffffffff81989000 0xffffffff8198b000     0          0 /boot/system/add-ons/kernel/drivers/power/acpi_battery
 1022 0xffffffff976e3000 0xffffffff97766000     0          0 /boot/system/add-ons/kernel/drivers/dev/net/iprowifi4965
 1026 0xffffffff81150000 0xffffffff81158000     0          0 /boot/system/add-ons/kernel/drivers/dev/graphics/intel_extreme
 1031 0xffffffff81a6b000 0xffffffff81a6f000     0          0 /boot/system/add-ons/kernel/drivers/dev/graphics/vesa
 1120 0xffffffff80276000 0xffffffff802a0000     0          0 /boot/system/add-ons/kernel/drivers/dev/net/marvell_yukon
 1592 0xffffffff806ee000 0xffffffff806f0000     0          0 /boot/system/add-ons/kernel/drivers/dev/input/wacom
 1593 0xffffffff80767000 0xffffffff80776000     0          0 /boot/system/add-ons/kernel/drivers/dev/input/usb_hid
 1825 0xffffffff81c76000 0xffffffff81c79000     0          0 /boot/system/add-ons/kernel/drivers/dev/bus/usb_raw
 1874 0xffffffff81cc3000 0xffffffff81ccf000     0          0 /boot/system/add-ons/kernel/drivers/dev/audio/hmulti/hda
 2408 0x0000003b215f7000 0x0000003b21808000     0          0 /boot/system/add-ons/Qt5/sqldrivers/libqsqlite.so
TEAM 3809 (/bin/grep --color=auto drivers):

Thanks. RR

comment:22 by tqh, 17 months ago

It is clearly an issue with old machines that have early ACPI implementations. I havn't found a way to fix this properly, one try was running shutdown on the boot cpu (old ACPI recommendation), but that causes a bigger problem. It sometimes creates a hard lock when disabling the other cpus on all hardware.

To solve this someone would need to have a special shutdown sequence for these old machines, but unfortunatly I don't have the hardware nor the time to test and implement such a solution. So I did a trade off so that shutdown work with most hardware.

Making these old computers to shutdown properly needs a labor of love from someone. It's likely to be a Sisyphus task, given how much time I spent on this already.

in reply to:  22 comment:23 by roiredxsoto, 16 months ago

Replying to tqh:

It is clearly an issue with old machines that have early ACPI implementations. I havn't found a way to fix this properly, one try was running shutdown on the boot cpu (old ACPI recommendation), but that causes a bigger problem. It sometimes creates a hard lock when disabling the other cpus on ....... Making these old computers to shutdown properly needs a labor of love from someone. It's likely to be a Sisyphus task, given how much time I spent on this already.

Thanks a lot anyway for answering. I know that this laptop is old and recently found out that arrow keys don't work properly (I found thanks to installing Haiku). Most likely, this old pal needs a substitute. Do not worry, I can live with the shutdown through powerswitch. ;)

Regards, RR

Last edited 16 months ago by roiredxsoto (previous) (diff)

comment:24 by pulkomandy, 16 months ago

Has a Patch: unset

comment:25 by -Meanwhile-, 14 months ago

The Eee PC 901 running R1/beta 1 (hrev52295+100 x86_gcc2) seems to shut down properly now, at least I've tried several times. Maybe bbjimmy can test his as well. Thanks tqh !

comment:26 by tqh, 10 months ago

Anyone who reported in this thread that still has problems?

comment:27 by -Meanwhile-, 10 months ago

My EeePC still hangs sometimes but it's not annoying really, just switch it off like you would do with many other devices.

comment:28 by khallebal, 10 months ago

Still doesn't poweroff hrev52840

Note: See TracTickets for help on using tickets.