Opened 20 months ago

Last modified 13 months ago

#14102 assigned bug

Incomplete GCC detection in configure

Reported by: axeld Owned by: waddlesplash
Priority: normal Milestone: Unscheduled
Component: Build System Version: R1/Development
Keywords: gcc configure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

It skips building the current version, because it has been built before. However, that version is out of date, so the build should actually be performed.

x86_gcc2 crosstools already exist in /home/axeld/develop/haiku/haiku/generated/cross-tools-x86_gcc2; skipping build
GCC version 2.95.3-haiku-2017_07_20 is required!
Please download it from www.haiku-os.org...

The last message is completely incorrect, anyway.

Change History (2)

comment:1 by waddlesplash, 13 months ago

Owner: changed from bonefish to waddlesplash
Status: newassigned

comment:2 by waddlesplash, 13 months ago

This is only an issue for GCC2, so I'm tempted to just leave it as-is...

Note: See TracTickets for help on using tickets.