#14103 closed enhancement (fixed)

Sync iprowifi3945 WLAN driver from FreeBSD 11.1

Reported by: cocobean Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Network/iprowifi3945 Version: R1/Development
Keywords: iprowifi3945 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Sync iprowifi3945 WLAN driver from FreeBSD 11.1

Attachments (3)

freebsd_11.1_wpi_driver.zip (47.0 KB) - added by cocobean 13 months ago.
FreeBSD 11.1 wpi driver original source (Latest commit e72339b on Apr 30, 2016)
iprowifi3945 (530.6 KB) - added by waddlesplash 13 months ago.
11.1 iprowifi3945 driver for x86_gcc2
iprowifi3945_test (1.4 KB) - added by cocobean 13 months ago.
syslog of iprowifi3945 Wifi outpu #1

Download all attachments as: .zip

Change History (15)

comment:1 Changed 13 months ago by cocobean

Last edited 13 months ago by cocobean (previous) (diff)

comment:2 Changed 13 months ago by waddlesplash

Um, what? No it isn't.

comment:3 Changed 13 months ago by cocobean

Confirmed that it says FreeBSD 9.3 in GIT. Thanks.

Changed 13 months ago by cocobean

Attachment: freebsd_11.1_wpi_driver.zip added

FreeBSD 11.1 wpi driver original source (Latest commit e72339b on Apr 30, 2016)

comment:4 Changed 13 months ago by waddlesplash

Uploading zips of unmodified source code is not useful, we know where to find it, thanks.

comment:5 Changed 13 months ago by cocobean

I'm porting the code to test on my own physical hardware as the current port is problematic on it.

comment:6 Changed 13 months ago by waddlesplash

Well, it won't work; it needs the new net80211 code as well as a bunch of other patches to the compatibility layer that are not in master. I have a WIP branch with most of them, however the iprowifi4965 driver that I've been trying to test them with KDLs after connecting to an AP.

comment:7 Changed 13 months ago by waddlesplash

The new net80211 code and the updated iprowifi4965 driver was merged in hrev52040. If you can tell me what device ID you have and what architecture you are on, I can merge and then get a test build of the new iprowifi3945 driver for you.

comment:8 Changed 13 months ago by cocobean

" device Network controller [2|80|0]

vendor 8086: Intel Corporation device 4222: PRO/Wireless 3945ABG [Golan] Network Connection"

Platform: Haiku x86_gcc2, Intel Core Duo Processor T2250 (Centrino Pro), Northbridge Intel i945PM 03, Southbridge Intel 82801GHM (ICH7-M/U) A1

*-network
                description: Wireless interface
                product: PRO/Wireless 3945ABG [Golan] Network Connection
                vendor: Intel Corporation
                physical id: 0
                bus info: pci@0000:06:00.0
                logical name: wlp6s0
                version: 02
                serial: 00:18:de:2c:39:8f
                width: 32 bits
                clock: 33MHz
                capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=iwl3945 driverversion=4.8.0-53-generic firmware=15.32.2.9 latency=0 link=no multicast=yes wireless=IEEE 802.11
                resources: irq:30 memory:40800000-40800fff

Last edited 13 months ago by cocobean (previous) (diff)

Changed 13 months ago by waddlesplash

Attachment: iprowifi3945 added

11.1 iprowifi3945 driver for x86_gcc2

comment:9 Changed 13 months ago by waddlesplash

Attached. SHA256sum should be 0e568836735579981fa36a21bf01691daf033c3e2da5b90e06528dafb4dc4003. I'm about to post testing instructions on the forum, so please look at that (or ask me on IRC.)

Changed 13 months ago by cocobean

Attachment: iprowifi3945_test added

syslog of iprowifi3945 Wifi outpu #1

comment:10 Changed 13 months ago by cocobean

NOTE: need to fix install-wifi-firmware.sh for correct website and any missing firmware files.

Seems it didn't load the firmware or lock memory properly - but I can disable/enable the driver without getting a KDL event and make attempts to join network without wpa_supplicant crashing (main issue with previous one). I need to do this from a test dev Live CD state to really track/test the exact same way (for a true clean test).

Last edited 13 months ago by cocobean (previous) (diff)

comment:11 Changed 13 months ago by waddlesplash

It looks like the driver was already loaded, which may be part of the problem. Please remove it, reboot, and then copy the new one into non-packaged. (See complete instructions at https://discuss.haiku-os.org/t/wi-fi-ethernet-testers-wanted/6998/2.)

comment:12 Changed 13 months ago by waddlesplash

Resolution: fixed
Status: newclosed

Merged the new driver in hrev52043.

Note: See TracTickets for help on using tickets.