Opened 12 years ago

Closed 11 years ago

#1416 closed bug (fixed)

"usb explore" thread sometimes crashes shortly after desktop is loaded

Reported by: stippi Owned by: mmlr
Priority: high Milestone: R1/alpha1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by stippi)

PANIC: vm_page_fault: unhandled page fault in kernael space at 0x7, ip 0x9639f7b0

Welcome to KDL...
kdebug> sc
stack trace for thread 0x24c "usb explore"
...
frame                     caller                    <image>:function + offset
...
iframe at 0x96552ef4  (end = 0x96552f48)
 eax 0x3              ebx 0x3             ecx 0x938c3000      edx 0x200246
 esi 0x90cbd500       edi 0x90cbd594      ebp 0x96552f58      esp 0x96552f24
 vector: 0xe, error code 0x0
96552eec (+ 108) 9639f7b0  </boot/.../bus_managers/usb>:RescanDrivers__5StackP11rescan_item + 0x0014
96552f58 (+  80) 963a12a3  <...>:Explore__3Hub + 0x028b
96552fa8 (+  48) 9639f5a9  <...>:ExploreThread__5StackPv + 0x0045
96552fd8 (+  32) 8003ae43  <...>:_create_kernel_thread_kentry + 0x001b
96552ff8 (+1772802056) 8003add8  <kernel>:thread_kthread_exit + 0x0000
kdebug> 

Puh... I typed that all. Hope I didn't sneak in any errors.

Change History (8)

comment:1 Changed 12 years ago by stippi

Description: modified (diff)

comment:2 Changed 12 years ago by axeld

Actual screenshots are welcome, too, though :-)

comment:3 Changed 12 years ago by mmlr

Milestone: R1R1/alpha
Status: newassigned

comment:4 Changed 12 years ago by stippi

Any news? :-)

comment:5 Changed 12 years ago by mmlr

Not really. It's difficult without being able to reproduce. I have looked over the explore code many times now and thought it was finally approaching stability. Do you have anything additional installed to the usb_hid driver when this occurs?

comment:6 Changed 12 years ago by mmlr

I have redesigned the explore process in hrev22929 and this might just have an effect on this bug. Can you please retest with a current revision and tell me whether it still happens?

comment:7 Changed 12 years ago by stippi

I was planning to test this as soon as I first read the commit, but have not gotten around it yet. Unfortunately, the notebook (my beloved T40p which ran Haiku so well) was stolen last week. This was the machine that had this error reproducably. I am not even sure if I ever saw that KDL on my other machines. But I will check.

comment:8 Changed 11 years ago by stippi

Resolution: fixed
Status: assignedclosed

Since I cannot reproduce this bug anymore, I am closing it for now, if I do happen to see it again, I can reopen it anyways...

Note: See TracTickets for help on using tickets.