Opened 12 years ago

Closed 12 years ago

#1417 closed bug (duplicate)

Media Preferences crashes with dropdown menu active followed by 'page' switch

Reported by: pieterpan Owned by: korli
Priority: normal Milestone: R1
Component: Preferences/Media Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Reproduce:

  • Start Media Preferences
  • Click on the Audio Settings 'page'
  • Select an Audio Input dropdown (click on it once to open the dropdown, don't activate your choice!).
  • Then go to Video Settings (or any other 'page')

Boom. "View method requires owner and doesn't have one"

Experienced behavior: Boom Expected behavior: Not boom (switch to Video Settings page).

Tested on rev 22027 in vmware on ubuntu

Attachments (2)

mediaprefscrash.png (89.7 KB ) - added by pieterpan 12 years ago.
Media Preferences crash
beforecrash.png (63.6 KB ) - added by pieterpan 12 years ago.

Download all attachments as: .zip

Change History (8)

by pieterpan, 12 years ago

Attachment: mediaprefscrash.png added

Media Preferences crash

comment:1 by marcusoverhagen, 12 years ago

Owner: changed from marcusoverhagen to korli

Reassigning to media preferences author. Korli if this is a interface kit bug, please reassign, too.

comment:2 by korli, 12 years ago

Can't reproduce. Could you provide a screenshot before the crash ?

by pieterpan, 12 years ago

Attachment: beforecrash.png added

comment:3 by pieterpan, 12 years ago

Perhaps interesting is that I have no soundcard detected, so the dropdown boxes are empty (vmware) Also, it happens about 50% of the time. It seems like it reproduces more often for the channel drop down, but I'm not sure.

After experimenting some more, I can make it crash for any of the drop downs on both the Audio Settings page AND the Video Settings page. All drop downs are empty, since I don't have an audio or video device. Sometimes it takes a few tries to make it happen.

If you need any other information, let me know I might be able to help some. After Friday (I have an exam coming up)

comment:4 by korli, 12 years ago

Can't reproduce.

comment:5 by diver, 12 years ago

I can reproduce it with hrev22554 under vmware and it's a dup of bug #573

comment:6 by korli, 12 years ago

Resolution: duplicate
Status: newclosed

I'm closing this one then.

Note: See TracTickets for help on using tickets.