Opened 12 years ago

Closed 12 years ago

#1418 closed bug (fixed)

Multiple rightclicks on trashcan: tracker crash

Reported by: pieterpan Owned by: jackburton
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Reproduce:

  • Right click on trashcan on desktop.
  • Do it again quickly, without closing the other popup.
  • Repeat if necessary

Boom. "AddChild failed - the view already has a parent."

Experienced behavior: crash Expected behavior: close of the old popup window, reopening of the new one.

Tested on rev 22027 in vmware on ubuntu Side note: I have IDE DMA disabled. Perhaps this slows the FS down to allow reproduction of this bug.

Attachments (1)

Fast Rightclick trashcan.png (85.5 KB) - added by pieterpan 12 years ago.
Right click trashcan too quickly: crash of tracker

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by pieterpan

Right click trashcan too quickly: crash of tracker

comment:1 Changed 12 years ago by jackburton

Component: - Applications/TrackerKits/Interface Kit
Owner: changed from axeld to jackburton

I can't reproduce this. Can you ?

comment:2 Changed 12 years ago by jackburton

Sorry, talked too fast: I could just reproduce it :)

comment:3 Changed 12 years ago by jackburton

Resolution: fixed
Status: newclosed

Fixed in hrev24005. Actually it has the same cause as #582: clicking outside a menu didn't close the menu itself.

Note: See TracTickets for help on using tickets.