Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#582 closed bug (fixed)

Deskbar displays empty Haiku menu

Reported by: koki@… Owned by: jackburton
Priority: normal Milestone: R1/alpha1
Component: Kits/Interface Kit Version:
Keywords: Cc: diver, olivier.coursiere@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

The Deskbar displays an empty Haiku menu under the following circumstances.

1) Click any of the window entries in the Deskbar (for example, Tracker) to display the option menu.

2) With the above option menu open, click on the Haiku menu (where the Haiku logo is). An empty menu with a white background is displayed.

This bug appeared in HAIKU revision 17432. Screenshot follows.

Attachments (3)

bug_17432_deskbar.png (8.0 KB) - added by koki@… 13 years ago.
Deskbar screenshot
emptyBeMenu.png (5.0 KB) - added by aldeck 12 years ago.
emptyBeMenuR5.png (6.0 KB) - added by aldeck 12 years ago.

Download all attachments as: .zip

Change History (31)

Changed 13 years ago by koki@…

Attachment: bug_17432_deskbar.png added

Deskbar screenshot

comment:1 Changed 13 years ago by jackburton

Owner: changed from sikosis to jackburton

comment:2 Changed 13 years ago by jackburton

Component: ApplicationsKits

comment:3 Changed 13 years ago by jackburton

Indeed. By the way this bug was already discussed in #233 's comments.

comment:4 Changed 13 years ago by jackburton

* Bug 712 has been marked as a duplicate of this bug. *

comment:5 Changed 13 years ago by jackburton

Cc: olivier.coursiere@… added

comment:6 Changed 13 years ago by diver

Cc: diver added

comment:7 Changed 13 years ago by jackburton

Status: newassigned

comment:8 Changed 13 years ago by jackburton

* Bug 292 has been marked as a duplicate of this bug. *

comment:9 Changed 13 years ago by diver

Another way to get there is to press leaf button and then alt+w...

comment:10 Changed 13 years ago by jackburton

Component: GeneralUser Interface/InterfaceKit
Description: modified (diff)
Platform: All

comment:11 Changed 12 years ago by jackburton

Resolution: fixed
Status: assignedclosed

Fixed in hrev20799

comment:12 Changed 12 years ago by diver

Cool!

comment:13 Changed 12 years ago by diver

Oh well those changes you've made didn't fix this bug, it just made it less likely to happen. I still see <empty> menu item sometimes when clicking on leaf. It even locked up once trying to reproduce this bug. Also current behavour is different from BeOS as you could click bemenu while teammenu is clicked down.

comment:14 in reply to:  13 Changed 12 years ago by jackburton

Replying to diver:

Oh well those changes you've made didn't fix this bug, it just made it less likely to happen. I still see <empty> menu item sometimes when clicking on leaf. It even locked up once trying to reproduce this bug.

Is there a reproducible way to do that ?

Also current behavour is different from BeOS as you could click bemenu while teammenu is clicked down.

Are you absolutely sure about that ? Because I changed the menu behaviour recently exactly to match beos's behaviour.

comment:15 Changed 12 years ago by leavengood

I found another way to reproduce this:

  1. Open the Haiku menu on the Deskbar. Leave it open.
  2. Use Alt-F2 to switch to the second workspace. The menu will disappear, but the Haiku button is still grayed like it is selected.
  3. Click on Tracker to get its team menu.
  4. Click back on the Haiku menu and the <empty> menu appears.

In BeOS if you switch workspace while the Be menu is open it is closed. In fact all menus close when workspaces are switched.

To fix this bug the Haiku app_server or interface kit needs to close open menus when workspaces are switched.

comment:16 Changed 12 years ago by leavengood

Actually I just tested some more and I can reproduce this using with the same steps as in the original bug report. If it matters I'm testing on VMWare and compiling with GCC 4.1.2.

comment:17 Changed 12 years ago by leavengood

Sorry to spam, but I just recompiled with GCC 2.95.3 (just in case) and I still see this problem.

comment:18 Changed 12 years ago by jackburton

Looks like it was since hrev21961. I am not saying that change it's wrong, but at least it made the bug show up again.

comment:19 Changed 12 years ago by jackburton

Resolution: fixed
Status: closedreopened

comment:20 Changed 12 years ago by jackburton

Milestone: R1R1/alpha

comment:21 Changed 12 years ago by aldeck

I could reproduce with the original bug description. Some graphics bugs are gone (see attached screenshot), but the <empty> menu item is still there. You can see the correct be menu for ~0.1 second though.

Also, while updating bug #478, i collected new info about this one.

If you drag'n'drop anything (text, file, folder) over the Be menu, the greyed <empty> menuitem replaces the correct be menu when you release the mouse (ie: when dropping).

The interesting thing is that it only happens if, while dragging to the Be menu, you roll over any team/app menuitem (wich puts the item in a "pushed-down" state, or selected state depending on what you drag).

Hope this helps

Changed 12 years ago by aldeck

Attachment: emptyBeMenu.png added

comment:22 Changed 12 years ago by aldeck

Happens _partially_ (my test case only) on R5. See screenshot. I hope i didn't hijack this ticket, as this reveals this might be caused by different bugs. Well, enough bug hunting for today! zzz...

Changed 12 years ago by aldeck

Attachment: emptyBeMenuR5.png added

comment:23 Changed 12 years ago by jackburton

Interesting... since it also happen on R5, either it's a bug in Deskbar, or a bug in the menu system we replicated (talk about compatibility, eh? :))... or even both :)

comment:24 Changed 12 years ago by jackburton

Resolution: fixed
Status: reopenedclosed

Fixed again in hrev24005.

comment:25 in reply to:  24 ; Changed 12 years ago by aldeck

Replying to jackburton:

Fixed again in hrev24005.

Hmm, the original bug seems fixed indeed. Although it might only be partially fixed, i just re-tested an older revision, the behavior has changed, i have to click one more time to open the leaf menu if a team/app menu is open as in the original bug description (hrev24004 ?).

Also, my test case is still bugged here, should we move it to a new ticket or you've got a fix in mind?

And to finish, #478 still crashes but it might be unrelated.

Regards, Alex

comment:26 in reply to:  25 Changed 12 years ago by jackburton

Replying to aldeck:

Replying to jackburton:

Fixed again in hrev24005.

Hmm, the original bug seems fixed indeed. Although it might only be partially fixed, i just re-tested an older revision, the behavior has changed, i have to click one more time to open the leaf menu if a team/app menu is open as in the original bug description (hrev24004 ?).

Yeah, but isn't this what happens on beos too ?

Also, my test case is still bugged here, should we move it to a new ticket or you've got a fix in mind?

Let's move it to a new ticket :)

And to finish, #478 still crashes but it might be unrelated.

Definitely.

comment:27 Changed 12 years ago by nielx

(spam)

comment:28 Changed 12 years ago by nielx

(spam2) Sorry, need to test if aldeck's CC works again.

Note: See TracTickets for help on using tickets.