Opened 15 months ago

Last modified 7 months ago

#14236 new bug

Thinkpads Trackpoint and Touchpad sometimes doesn't work after boot

Reported by: miqlas Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Input/PS2 Version: R1/Development
Keywords: touchpad, trackpoint Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Happend with x200s and now with T440s.

The trackpoint (the small red rubber thing in the middle of the keyboard) mostly works, but sometimes it is dead after booting Haiku.

I would say there is 3 cases:

  • after boot trackpoint and touchpad works ok
  • after boot trackpoint dead, touchhpad works ok
  • after boot neither works

(- i haven't seen yet working trackpoint but dead Touchpad)

Interestingly in the third case the Touchpad recognizes the first 1-2 mm movement, but then it never reacts anymore. A reboot solves this problem. Keyboard is not affected.

In the syslog i see only: "KERN: ps2: reset failed"

Haiku: x86_64 hrev52047.

Attachments (1)

syslog.trackpoint.grep (488 bytes ) - added by miqlas 15 months ago.
Grepped syslog

Download all attachments as: .zip

Change History (4)

by miqlas, 15 months ago

Attachment: syslog.trackpoint.grep added

Grepped syslog

comment:1 by cb88, 13 months ago

I see something very similar on my x131e AMD e2-1800. Seems to run Hrev52246 pretty well other than no wifi (its BCM43228 I may have a realtek or intel card I can switch it to will have to check but it has to be on the laptop's whitelist unfortunately)

I installed Haiku from qemu wit -cdrom anyboot.iso -device file=/dev/sda,index=0,type=disk,format=raw -boot d

rebooted (chainloaded the Haiku partition from syslinux) trackpad worked on the first native reboot, trackpoint did not, warm rebooted same thing, also the trackpad was acking wierd button clicks were not working as expected and it was registering clicks from the touchpad itself too often making it hard to go through the menus etc.. did a cold reboot and it works. Note the syslog still shows the PS/2 reset errors but it works seemingly without issues both trackpad and trackpoint are very usable. Syslog on the working reboot says reset failed, after loading the ps2 driver, right after /input/mouse/ps2/0 is published and right after ps2/1 is published, this is followed by ps2/2 and ps2/synaptics_3, the keyboard and then ps2/ibm_trackpoint_3 being published. I can attach syslogs once I get it on the internet if needed.

Note the wifi on this laptop experiences a similar issue on Linux/Windows, sometimes it doesn't come up after a warm reboot. Through I haven't noticed this yet on Linux 4.17 it may have been fixed.

Also note I have 5 of these laptops very robust but not very fast... runs Haiku snappily though. One on the nicest keyboards you'll find on a subnotebook.

Last edited 13 months ago by cb88 (previous) (diff)

comment:2 by diver, 13 months ago

#3152 and #3125 could be related. There are links to a few commits with possible regressions.

comment:3 by waddlesplash, 7 months ago

Component: Drivers/MouseDrivers/Input/PS2
Keywords: ps2 removed
Note: See TracTickets for help on using tickets.