#14272 closed bug (fixed)

ahci: executeAtaRequest port 4: device timeout

Reported by: pragmavalue Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Disk Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

Hi,

Haiku doesn't boot on my M.2 SSD.

Attachments (1)

IMG_20180714_083820.jpg (273.1 KB ) - added by pragmavalue 15 months ago.

Download all attachments as: .zip

Change History (12)

by pragmavalue, 15 months ago

Attachment: IMG_20180714_083820.jpg added

comment:1 by pragmavalue, 15 months ago

This ticket concerns a hrev 52098. And System is install on normal HDD.

comment:2 by diver, 15 months ago

Component: DriversDrivers/Disk
Description: modified (diff)
Summary: M.2 and AHCI problemahci: executeAtaRequest port 4: device timeout

comment:3 by diver, 15 months ago

Can you enable tracing in ahci, rebuild Haiku and grab a syslog or take more pics?

comment:4 by korli, 15 months ago

Please try hrev52090 or older.

comment:5 by diver, 15 months ago

He was using hrev52098.

comment:6 by korli, 15 months ago

@diver I know, I was saying to try before hrev52091 (which introduces https://git.haiku-os.org/haiku/commit/?id=ffd36865cf3e66a57f5b1c5e938d53bdbd1c9933 ).

comment:7 by diver, 15 months ago

Ah, I misread it. Thanks :)

comment:8 by waddlesplash, 15 months ago

Possibly a duplicate of #10737.

comment:9 by pragmavalue, 15 months ago

Yes, i tryed with older hrev52044 and a make new ticket with smap...

@waddelespalsh

This new hardware Desktop not, a Laptop but from vendor AMD...

comment:10 by waddlesplash, 15 months ago

Just to double-check: This does occur with hrev52098, and the system continues booting with hrev52044, universally; i.e. it's not intermittent like #10737 suggests?

comment:11 by waddlesplash, 15 months ago

Resolution: fixed
Status: newclosed

Fixed in hrev52107.

Note: See TracTickets for help on using tickets.