Opened 3 months ago

Closed 2 months ago

#14326 closed bug (fixed)

MediaPlayer: audio streaming broken

Reported by: KapiX Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

stream: http://live-icy.gss.dr.dk:8000/A/A29H.mp3

Culprit: https://git.haiku-os.org/haiku/commit/?id=3248de3de47011137e0c667a7247dd424c827bd7

Changing mode to never remember position before ever playing the stream doesn't help.

Change History (10)

comment:1 Changed 3 months ago by waddlesplash

Owner: changed from stippi to Barrett
Status: newassigned

comment:2 Changed 3 months ago by korli

Owner: changed from Barrett to waddlesplash

@waddlesplash I think you merged the commit in the description.

comment:3 Changed 3 months ago by waddlesplash

Owner: changed from waddlesplash to pulkomandy

It looks like PulkoMandy did?

comment:4 Changed 3 months ago by pulkomandy

I pushed it for review, but you merged it. I currently don't have a working soundcard which doesn't ease testing...

comment:5 Changed 3 months ago by pulkomandy

Resolution: fixed
Status: assignedclosed

Fixed in hrev52178.

comment:6 Changed 2 months ago by KapiX

Resolution: fixed
Status: closedreopened

Still broken for me as of hrev52205. If I run MediaPlayer http://live-icy.gss.dr.dk:8000/A/A29H.mp3 I get one playlist item with duration of 0:05.

comment:7 Changed 2 months ago by pulkomandy

This looks like a different problem. Maybe caused by the recent changes in the ffmpeg decoder?

[mp3 @ 0x18cd0680] Estimating duration from bitrate, this may be inaccurate

ffmpeg somehow doesn't "get" that this is a stream and will play endlessly. It may be because Barrett removed the link between the ffmpeg codec and container in https://git.haiku-os.org/haiku/commit/?id=9467826d3121b639c710199b11ffa56e702aab13 ?

comment:8 Changed 2 months ago by pulkomandy

Resolution: fixed
Status: reopenedclosed

Fixed in hrev52206.

comment:9 Changed 2 months ago by pulkomandy

Resolution: fixed
Status: closedreopened

Now podcasts (which are downloaded but have a fixed duration) won't allow seeking. So the "streaming" flag doesn't do what I expected.

comment:10 Changed 2 months ago by pulkomandy

Resolution: fixed
Status: reopenedclosed

Fixed properly in hrev52212.

Note: See TracTickets for help on using tickets.