Opened 2 years ago

Last modified 9 months ago

#13092 reopened bug

Audio CD's stutter and cut out

Reported by: vidrep Owned by: kallisti5
Priority: normal Milestone: Unscheduled
Component: Drivers/Disk/ATA Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #14388
Has a Patch: no Platform: All

Description

hrev50710 x86_gcc2 Playing a store bought audio CD with MediaPlayer on internal optical drive causes the audio to stutter and cut out. Thinking it might be a defective drive, I installed a second one with the same result. The problem is also apparent on a second Haiku PC, but somewhat less noticible. Attached are syslog and screenshots of the hardware being used.

Attachments (11)

syslog (154.6 KB) - added by vidrep 2 years ago.
Devices_Basic_Information.png (120.3 KB) - added by vidrep 2 years ago.
Devices_SCSI_Information.png (125.6 KB) - added by vidrep 2 years ago.
Devices_Detailed.png (141.4 KB) - added by vidrep 2 years ago.
DriveSetup.png (98.9 KB) - added by vidrep 2 years ago.
VLC_log.txt (111.4 KB) - added by vidrep 2 years ago.
syslog.2 (463.7 KB) - added by vidrep 2 years ago.
listdev (3.1 KB) - added by vidrep 2 years ago.
UserBuildConfig (1.6 KB) - added by vidrep 2 years ago.
ata_debug_syslog (318.3 KB) - added by vidrep 2 years ago.
devicerecalibrate error (34.0 KB) - added by thaflo 9 months ago.
device recalibrate error

Download all attachments as: .zip

Change History (23)

Changed 2 years ago by vidrep

Attachment: syslog added

Changed 2 years ago by vidrep

Changed 2 years ago by vidrep

Changed 2 years ago by vidrep

Attachment: Devices_Detailed.png added

Changed 2 years ago by vidrep

Attachment: DriveSetup.png added

comment:1 Changed 2 years ago by vidrep

Playing a CD with VLC 0.8.6i has the same result. Attached is a log of the VLC messages.

Changed 2 years ago by vidrep

Attachment: VLC_log.txt added

comment:2 Changed 2 years ago by vidrep

hrev50749 x86_gcc2 Issue is still apparent on this hardware. Perhaps some info can be gleaned from the most recent syslog (attached).

Changed 2 years ago by vidrep

Attachment: syslog.2 added

Changed 2 years ago by vidrep

Attachment: listdev added

comment:3 Changed 2 years ago by vidrep

I installed Lubuntu Linux to a spare partition on the same HD alongside Haiku. The same audio CD that cuts out and stutters on Haiku plays perfectly on Linux. If any further data is required to resolve the issue, please let me know.

comment:4 Changed 2 years ago by vidrep

Component: Applications/MediaPlayerDrivers/Disk/ATA
Owner: changed from stippi to kallisti5
Status: newassigned

comment:5 Changed 2 years ago by vidrep

I built a Haiku anyboot image from master, with debugging enabled for the ata bus. I have attached a copy of the "userbuildconfig" as I configured it for this build. The attached syslog is from a fresh install (first boot), single audio CD track played with MediaPlayer.

Changed 2 years ago by vidrep

Attachment: UserBuildConfig added

Changed 2 years ago by vidrep

Attachment: ata_debug_syslog added

comment:6 Changed 22 months ago by vidrep

I no longer have the PC available for further testing. Perhaps this ticket can be closed on account of that.

comment:7 Changed 10 months ago by waddlesplash

Resolution: not reproducible
Status: assignedclosed

comment:8 Changed 10 months ago by CodeforEvolution

Not so fast, for I have observed this problem on my pc too. It is a Dell Optiplex 745. Unfortunately, I’m away from the pc so I can’t provide more detailed information. For now, it’s best to reopen the ticket.

comment:9 Changed 10 months ago by waddlesplash

Resolution: not reproducible
Status: closedreopened

Are you sure it's not a more general audio stuttering problem? We've seen those too.

comment:10 Changed 10 months ago by CodeforEvolution

Not exactly, to describe it, I’d play an Audio CD with MediaPlayer, for a few seconds it would play normally, and then it cuts out, yet MediaPlayer seemingly continues to play nothing (seconds increase on duration). Copying the file off the cd allows the file to play without issue.

comment:11 Changed 9 months ago by vidrep

Blocking: 14388 added

Changed 9 months ago by thaflo

Attachment: devicerecalibrate error added

device recalibrate error

comment:12 Changed 9 months ago by thaflo

tried to copy the content of a audio CD file to the Desktiop/music folder. Then I got multiple "device recalibrate error" windows. Maybe we step a bit further with this issue and this hint helps. see ticket #4482, as there are the same issues encountering. Haiku doesn't like CDs, it seems

Last edited 9 months ago by thaflo (previous) (diff)
Note: See TracTickets for help on using tickets.