Opened 17 months ago

Last modified 3 weeks ago

#14571 reopened bug

[Build System] beta image includes 36 source packages

Reported by: diver Owned by: bonefish
Priority: normal Milestone: Unscheduled
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Haiku Beta1 image.

36 source packages consumes ~300MB of image space should not be there.

Change History (13)

comment:1 by diver, 17 months ago

36 source packages ~300mb
+ 9 devel packages ~15mb
How come?

comment:2 by waddlesplash, 17 months ago

Huh? This is intentional; we ship source packages with the release image so we can sell it and not have to worry about separately distributing sources for GPL compliance.

comment:3 by diver, 17 months ago

Hm, ok. What about devel packages?

comment:4 by diver, 17 months ago

I confirmed on Telegram that this is could be an issue indeed. Someone couldn't boot Haiku with 375 MB RAM (it was deadlocking after loading Tracker). I suggested to try a nightly and it booted up with no problems. With 132 MB used.

comment:5 by pulkomandy, 5 weeks ago

Resolution: invalid
Status: newclosed

Source packages will not be removed for legal reasons. We couldn't conveniently sell DVDs not containing them, because if we did this, we would be bound by the GPL to allow people to request the sources by the same channel (buying a DVD) for a few years after the buy the runnable one.

Providing the sources directly on the same disk solves this.

The problem with booting will be fixed with #15621.

comment:6 by diver, 5 weeks ago

Nice! Does it also fix preinstalled devel packages?

comment:7 by pulkomandy, 5 weeks ago

No. The source packages are made completely uninstallable by this. But devel packages need to be installable still, so for these, we need the checkboxes in Installer to work. I'll look into that tomorrow

comment:8 by diver, 5 weeks ago

I meant that something pulled in 9 devel packages into beta1 image. Something to check before release.

In any case, looking forward to seeing checkboxes working in Installer! :)

comment:9 by pulkomandy, 5 weeks ago

I think they are intentional. We ship a minimal development environment with the nightlies to attract new developers. I will however move them to _packages_ so they are disabled in the live cd and only enabled while installing.

comment:10 by diver, 3 weeks ago

At first I thought that these packages are dependencies of haiku_devel and that's why there were pulled in but it turned out it doesn't have any deps. I also grepped for devel in haiku/build/jam/images with no result. So i'm really not sure why they are getting pulled in. Ideas?

curl_devel-7.66.0-1-x86_64.hpkg
glu_devel-9.0.0-7-x86_64.hpkg
haiku_devel-r1~beta1_hrev53819-1-x86_64.hpkg
jpeg_devel-9c-2-x86_64.hpkg
libpng16_devel-1.6.37-1-x86_64.hpkg
mesa_devel-17.1.10-5-x86_64.hpkg
nghttp2_devel-1.34.0-1-x86_64.hpkg
openssl_devel-1.0.2t-1-x86_64.hpkg
zlib_devel-1.2.11-3-x86_64.hpkg

comment:11 by pulkomandy, 3 weeks ago

Nothing is pulled in, there is a hardcoded list of packages in the build profile. I think these used to be recuired to compile Haiku, but we've since changed haiku buildsystem to download them itself so I think they can be removed now?

comment:12 by diver, 3 weeks ago

I think so, yes. Can we then hide optional packages expander if none are found?

comment:13 by diver, 3 weeks ago

Resolution: invalid
Status: closedreopened

I'll reopen if so it's not forgotten.

Note: See TracTickets for help on using tickets.