Opened 8 months ago

Last modified 7 weeks ago

#14623 reopened bug

[Battery Status] Haiku hangs on starting Akku-Info

Reported by: Morbid Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Akku full charged nearly 100% (BIOS). Battery Status installed in Tracker is at 66%. Heavy load in Process Control after starting Akku-Info (see Video). Unable to move the mouse. Have to reboot via STRG-ALT-Entf (4Sec) or push the Power-Button.

Attachments (8)

02About.jpg (427.3 KB) - added by Morbid 8 months ago.
01Bios_Laptop_1.jpg (391.8 KB) - added by Morbid 8 months ago.
03Akku-Info.mp4 (2.8 MB) - added by Morbid 8 months ago.
Dell_Latitude_syslog_OLD.txt (512.0 KB) - added by Morbid 8 months ago.
syslog_Dell.txt (188.2 KB) - added by Morbid 8 months ago.
screenshot1.jpeg (123.1 KB) - added by Morbid 6 months ago.
Top_screen.JPG (1.7 MB) - added by Morbid 5 months ago.
syslog_old.txt (512.0 KB) - added by Morbid 5 months ago.

Change History (26)

Changed 8 months ago by Morbid

Attachment: 02About.jpg added

Changed 8 months ago by Morbid

Attachment: 01Bios_Laptop_1.jpg added

Changed 8 months ago by Morbid

Attachment: 03Akku-Info.mp4 added

Changed 8 months ago by Morbid

Changed 8 months ago by Morbid

Attachment: syslog_Dell.txt added

comment:1 Changed 7 months ago by Morbid

No Problems with Haiku R1/alpha4.1. (description above Deskbar instead Tracker, sorry)

comment:2 Changed 7 months ago by diver

Resolution: fixed
Status: newclosed

comment:3 Changed 6 months ago by diver

Resolution: fixed
Status: closedreopened

Bah, misread your comment. Sorry.

comment:4 Changed 6 months ago by Morbid

Probably my fault. My English is sometimes a little cryptic. (lol)

comment:5 Changed 6 months ago by diver

Can you run tail -F /var/log/syslog in Terminal and only then start BatteryStatus?

Changed 6 months ago by Morbid

Attachment: screenshot1.jpeg added

comment:6 Changed 6 months ago by Morbid

Also did a reinstallation of Haiku Beta1 (same Version as in 02About.jpg).

comment:7 Changed 6 months ago by diver

Did it hang this time?

comment:8 Changed 6 months ago by Morbid

Yes it hangs again, the equal behavior as in 03Akku-Info.mp4. Tried same Haiku Version but 64Bit on Lenovo B50-10 (booted via Live-DVD) and it works correct.

Last edited 6 months ago by Morbid (previous) (diff)

comment:9 Changed 5 months ago by Morbid

Did an installation of hrev52632 (x86). On booting i've got a KDL about iprowifi2200 (maybe another ticket). After Blacklist this device Haiku was booting normal, but again with the same behavior as in 03Akku-Info.mp4.

comment:10 Changed 5 months ago by waddlesplash

Without actually seeing what thread is using so much CPU and an actual syslog after the fault occurs, this will be impossible to debug or fix.

comment:11 Changed 5 months ago by Morbid

Would Top help in a Terminal-Window?

Changed 5 months ago by Morbid

Attachment: Top_screen.JPG added

Changed 5 months ago by Morbid

Attachment: syslog_old.txt added

comment:12 Changed 5 months ago by Morbid

Smells like a problem with ACPI. Would it help to reinstall Haiku R1/Alpha4.1 to compare both syslogs?

comment:13 Changed 5 months ago by tqh

Most likely seeing CPU from ACPI here would be if the hardware ACPI lock is taken by hardware. Then you should start by checking if you have a firmware update as that is a bad firmware issue. Also I just upgraded ACPICA version, so try latest Haiku build hrev52667 as well.

comment:14 Changed 5 months ago by Morbid

First of all. Thanks to everyone who was trying to investigate. Did an installation from hrev52667 as recommended and also disabled everything that i found under Power Management in the BIOS and it don't work. It's the same as in Top_screen.jpg and 03Akku-Info.mp4. The BIOS itself was updated to latest version for this Machine to A16 (Orginal Files from Dell long ago). Question: Why it works with Alpha4.1?

comment:15 Changed 5 months ago by tqh

Not sure if that version had proper locking or not: if the text in battery info ever got garbled it did not. Also ACPICA which we use did a lot of extra handling in early versions, so your laptop may need certain handling. I will take a look what we used back then.

comment:16 Changed 5 months ago by Morbid

Stay tuned, please. This time i'll keep the Hardware. (lol)

comment:17 Changed 8 weeks ago by Morbid

One Question: When starts the first changes in Deskbar and Tracker? Til witch hrev of Haiku are the old Deskbar and Tracker (after Alpha4) in use (without changes)?

Last edited 8 weeks ago by Morbid (previous) (diff)

comment:18 Changed 7 weeks ago by Morbid

Did an installation with Haiku hrev46000. Running extended Akku-Info. Values (%) are equal with BIOS. Icon to the left of "Akku unused" is empty. By clicking on this empty Symbol the CPU is under heavy load.

Note: See TracTickets for help on using tickets.