Opened 21 months ago

Closed 21 months ago

Last modified 4 months ago

#14715 closed bug (duplicate)

Tracker - becomes unresponsive when copying a bunch of files to a USB flashdrive

Reported by: dcatt Owned by: nobody
Priority: high Milestone:
Component: Drivers/Disk/USB Version: R1/beta1
Keywords: Cc:
Blocked By: #14504 Blocking:
Platform: All

Description

I noticed that when copying a bunch of files to a USB flashdrive that Tracker becomes unresponsive and can't even be killed via Team Monitor.

Not sure if this bug is similar/related to #10695

Steps to Reproduce

  1. get/create a bunch of files that are 1+ MB in size
  2. mount a USB flashdrive
  3. drag-n-drop files to USB flashdrive
  4. (BUG) observe that are a few seconds Tracker becomes unresponsive

Expected Results

Tracker remains responsive and files get copied to the USB flashdrive without issue.

Actual Results

Currently, when copying a bunch of files to a USB flashdrive, Tracker becomes unresponsive and the copying of files basically fails to complete.

Attachments (3)

screencast.webm (4.4 MB ) - added by dcatt 21 months ago.
write_files.rb (380 bytes ) - added by dcatt 21 months ago.
syslog (29.4 KB ) - added by dcatt 21 months ago.

Change History (8)

by dcatt, 21 months ago

Attachment: screencast.webm added

by dcatt, 21 months ago

Attachment: write_files.rb added

comment:1 by diver, 21 months ago

Please attach your syslog.

by dcatt, 21 months ago

Attachment: syslog added

comment:2 by dcatt, 21 months ago

diver, syslog attached!

comment:3 by diver, 21 months ago

Component: Applications/TrackerDrivers/Disk/USB

It looks like Tracker is just a victim of underlying usb_disk driver bug:

KERN: usb_disk: acquire_sem failed while waiting for data transfer: Operation timed out
KERN: usb error control pipe 9: timeout waiting for queued request to complete

comment:4 by diver, 21 months ago

Blocked By: 14504 added
Resolution: duplicate
Status: newclosed

comment:5 by nielx, 4 months ago

Milestone: Unscheduled

Remove milestone for tickets with status = closed and resolution != fixed

Note: See TracTickets for help on using tickets.