Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#148 closed bug (fixed)

Text cursor drawing bug at TextControl

Reported by: sil2100@… Owned by: bpmagic@…
Priority: low Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

To see this bug, one needs to open any application using BTextControl - for instance Keyboard prefs app. After clicking on the text area, the beam cursor draws a small white rectangle that overlaps the blue border of the activated TextControl item. Additionally, highlighted text also seems to be affected.

Attaching image.

Attachments (1)

textcontrol_cursor_problem.png (14.9 KB) - added by sil2100@… 13 years ago.
Text cursor problem example

Download all attachments as: .zip

Change History (14)

comment:1 Changed 13 years ago by sil2100@…

attachments.description: I beam cursor problem exampleText cursor problem example

comment:2 Changed 13 years ago by sil2100@…

Summary: I_beam cursor drawing bug at TextControlText cursor drawing bug at TextControl

Changed 13 years ago by sil2100@…

Text cursor problem example

comment:3 Changed 13 years ago by johndrinkwater

dup of #116

comment:4 Changed 13 years ago by sil2100@…

Resolution: duplicate

comment:5 Changed 13 years ago by sil2100@…

* This bug has been marked as a duplicate of #116 *

comment:6 Changed 13 years ago by sil2100@…

Status: newclosed

comment:7 Changed 13 years ago by stippi

Status: closedreopened

comment:8 Changed 13 years ago by stippi

Sorry, but this is a separate bug. Without having looked into it,I would think that the R5 cursor data to 32 bit bitmap conversionis broken. That would be a simply and quite possible explaination.Bug 116 is something different.

comment:9 Changed 13 years ago by stippi

Resolution: duplicate

comment:10 Changed 13 years ago by jackburton

So, in your opinion, the two images in #116 (the second one seems to show the same problem as the image attached here) aren't the result of the same bug ?

comment:11 Changed 13 years ago by jackburton

Resolution: fixed

comment:12 Changed 13 years ago by jackburton

Status: reopenedclosed

comment:13 Changed 13 years ago by jackburton

Fixed by stippi

Note: See TracTickets for help on using tickets.