Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1488 closed bug (duplicate)

Cortex doesn't work in Vmware server while emulating an Realtek Ac97 audio card

Reported by: lxstoian Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Servers/media_addon_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Cortex doesn't work in Vmware server while emulating an Realtek Ac97 audio card.

This is the debug screen. http://img165.imageshack.us/img165/4246/cortexqv1.png

Change History (8)

comment:1 Changed 12 years ago by marcusoverhagen

Please attach the vmx file you are using with vmware.

comment:2 Changed 12 years ago by stippi

Hi lxstoian,

whenever you are in the debugger window, could you please type the command "bt" and hit enter? This will print the "stack trace" of the thread which caused the error, which is a great help in analyzing the problem.

Thanks, -Stephan

comment:3 Changed 12 years ago by stippi

Component: - Audio & VideoServers/media_addon_server

Changing components, since the crash is actually happening in the media_addon_server.

comment:4 Changed 12 years ago by lxstoian

comment:5 Changed 12 years ago by axeld

This seems to be a duplicate of bug #1450 - or is that device actually supported? Can you have a look in the Media prefs to see if it appears?

Also, please attach screenshots to this bug, and don't use external links when possible.

comment:6 Changed 12 years ago by lxstoian

The device doesn't appear in the Media prefs. When I use the haiku weekly image from Haikuware I have sound that works and cortex works too.

From now on I'll use only attach.

comment:7 Changed 12 years ago by axeld

Resolution: duplicate
Status: newclosed

Thanks for the update, so it's indeed a duplicate!

comment:8 Changed 12 years ago by umccullough

The Haikuware image likely contains the OpenSound port from mmu_man - which doesn't work very well last I checked (choppy sound).

OSS supports many chipsets, including the es1371 available in VMware.

OpenSound is not part of the Haiku repo, and not compiled with "official" factory images.

Note: See TracTickets for help on using tickets.