Opened 12 years ago

Closed 11 years ago

#1489 closed bug (fixed)

Add Icon in File Type gives General system error in Icon-O-Matic

Reported by: scottmc Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/Icon-O-Matic Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I right click on my Haiku volume and select File Type, than right click on Icon space and select Add Icon... Icon-O-Matic opens up but gives an Error: General system error As I recall a General system error is what is called if there is no defined error to be displayed. Perhaps this just needs to have the proper error displays. I'm guessing it's because there was no icon in the blank space to begin with?

Attachments (2)

add-icon.png (21.3 KB ) - added by scottmc 12 years ago.
icon-o-error.png (19.1 KB ) - added by scottmc 12 years ago.

Download all attachments as: .zip

Change History (7)

by scottmc, 12 years ago

Attachment: add-icon.png added

by scottmc, 12 years ago

Attachment: icon-o-error.png added

comment:1 by axeld, 12 years ago

Component: Add-Ons/Tracker- Applications/Icon-O-Matic
Owner: changed from axeld to stippi

comment:2 by scottmc, 11 years ago

I just checked this one on hrev25892 and it's still there. [Bummer]

comment:3 by scottmc, 11 years ago

Perhaps "Add Icon..." should open up a file select box on a folder that has icons in it? And maybe add another option (or two) for "New Icon" which would open Icon-O-Matic in a mode that would be ready to create a new icon, and give no error. Perhaps the other option would be "Edit Icon" which would be greyed out if no icon is yet present.

comment:4 by scottmc, 11 years ago

Did this just get fixed, or is there still more to happen?

comment:5 by stippi, 11 years ago

Resolution: fixed
Status: newclosed

Oh yeah, thanks a lot for helping me stay on top of trac! Really. Fixed in hrev27065.

Note: See TracTickets for help on using tickets.