Opened 12 years ago

Closed 12 years ago

#1508 closed bug (fixed)

Odd behavior from shutdown -r

Reported by: anevilyak Owned by: axeld
Priority: normal Milestone: R1/alpha1
Component: Drivers/Keyboard/PS2 Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When I run shutdown -r from the Safe mode console, all works as expected. When I run it from a fully booted Haiku system, it results in a power off instead of a reboot. Ditto if the graphical reboot from Deskbar is used.

Hardware: Athlon64 3200+ Asus A8N-SLI motherboard (Nforce4/PCI Express) ATI X800XL PCI-Express 1GB RAM Sound Blaster Live PCI

Let me know if further information is needed, no special changes to any config files have been made.

Change History (7)

comment:1 Changed 12 years ago by axeld

Milestone: R1R1/alpha

comment:2 Changed 12 years ago by plfiorini

I cannot reproduce it on hrev22535 both shutdown -r on console and graphical restart from deskbar reboot (on vmware).

comment:3 Changed 12 years ago by anevilyak

It does indeed work fine in VMWare...real hardware is a different kettle of fish though, much more variety there. Also iirc one of Axel's laptops likewise has strange issues with shutdown which might be related.

comment:4 Changed 12 years ago by axeld

Can you reproduce this problem with hrev22617 or later?

comment:5 Changed 12 years ago by anevilyak

Will give it a try, though depending on work that may have to wait for the weekend. Is your laptop no longer having issues?

comment:6 Changed 12 years ago by anevilyak

Confirmed as fixed, I get a correct reboot now.

comment:7 Changed 12 years ago by axeld

Component: System/KernelDrivers/Keyboard/PS2
Resolution: fixed
Status: newclosed

Great, thanks! So that binary search recompile hours have paid off :-)

Note: See TracTickets for help on using tickets.