Opened 10 months ago

Closed 10 months ago

Last modified 6 weeks ago

#15226 closed bug (fixed)

KDL: attempt to acqure lock twice on non-SMP system

Reported by: nephele Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: #15223 Blocking:
Platform: All

Description (last modified by mmlr)

fusesmb crashed, i clicked save report and then i got a lot of those (tried to use exit to continue) hrev53337

KERN: PANIC: acquire_spinlock: attempt to acquire lock 0xffffffff80295e90 twice on non-SMP system (last caller: 0x0000000000000000, value 1dc23b90)
KERN: Welcome to Kernel Debugging Land...
KERN: Thread 1365 "Debugger" running on CPU 0
KERN: stack trace for thread 1365 "Debugger"
KERN:     kernel stack: 0xffffffff80291000 to 0xffffffff80296000
KERN:       user stack: 0x00007ffd1cc25000 to 0x00007ffd1dc25000
KERN: frame                       caller             <image>:function + offset
KERN:  0 ffffffff80295b78 (+  24) ffffffff8014db7c   <kernel_x86_64> arch_debug_call_with_fault_handler + 0x16
KERN:  1 ffffffff80295b90 (+  80) ffffffff800ad638   <kernel_x86_64> debug_call_with_fault_handler + 0x88
KERN:  2 ffffffff80295be0 (+  96) ffffffff800aefc1   <kernel_x86_64> kernel_debugger_loop(char const*, char const*, __va_list_tag*, int) + 0xf1
KERN:  3 ffffffff80295c40 (+  80) ffffffff800af2be   <kernel_x86_64> kernel_debugger_internal(char const*, char const*, __va_list_tag*, int) + 0x6e
KERN:  4 ffffffff80295c90 (+ 240) ffffffff800af627   <kernel_x86_64> panic + 0xb7
KERN:  5 ffffffff80295d80 (+  48) ffffffff80077869   <kernel_x86_64> acquire_spinlock + 0x129
KERN:  6 ffffffff80295db0 (+  64) ffffffff80055614   <kernel_x86_64> ConditionVariable::_Notify(bool, int) + 0x34
KERN:  7 ffffffff80295df0 (+  32) ffffffff800c5429   <kernel_x86_64> finish_debugger_change(BKernel::Team*) + 0x49
KERN:  8 ffffffff80295e10 (+ 272) ffffffff800c616c   <kernel_x86_64> install_team_debugger(int, int, int, bool, bool) + 0x5dc
KERN:  9 ffffffff80295f20 (+  16) ffffffff8014f578   <kernel_x86_64> x86_64_syscall_entry + 0xfb
KERN: user iframe at 0xffffffff80295f30 (end = 0xffffffff80295ff8)
KERN:  rax 0xe4                  rbx 0x3a0                 rcx 0x48408cfa74
KERN:  rdx 0x7ffd1dc23ba2        rsi 0x3a0                 rdi 0x53e
KERN:  rbp 0x7ffd1dc23c40         r8 0x7ffd1dc21484         r9 0x0
KERN:  r10 0x48408cf954          r11 0x3206                r12 0x9f1540
KERN:  r13 0x7ffd1dc23cf8        r14 0x53e                 r15 0x9d07c0
KERN:  rip 0x48408cfa74          rsp 0x7ffd1dc23b78     rflags 0x3206
KERN:  vector: 0x63, error code: 0x0
KERN: 10 ffffffff80295f30 (+140727247494416) 00000048408cfa74   <libroot.so> _kern_install_team_debugger + 0x0c
KERN: 11 00007ffd1dc23c40 (+ 144) 00000179d78ad933   <libdebugger.so> LocalTargetHostInterface::Attach const(int, int, DebuggerInterface*&) + 0x43
KERN: 12 00007ffd1dc23cd0 (+  96) 00000179d78ac41f   <libdebugger.so> TargetHostInterface::_StartTeamDebugger(int, TeamDebuggerOptions const&, bool) + 0x5f
KERN: 13 00007ffd1dc23d30 (+  96) 00000179d78ac642   <libdebugger.so> TargetHostInterface::StartTeamDebugger(TeamDebuggerOptions const&) + 0x72
KERN: 14 00007ffd1dc23d90 (+  96) 0000019d01263c16   <_APP_> ReportDebugger::Run(Options const&) + 0x86
KERN: 15 00007ffd1dc23df0 (+ 624) 0000019d012630ab   <_APP_> main + 0xbb
KERN: 16 00007ffd1dc24060 (+  48) 0000019d0126322e   <_APP_> _start + 0x3e
KERN: 17 00007ffd1dc24090 (+  48) 000002114fa6e575   </boot/system/runtime_loader@0x000002114fa5a000> <unknown> + 0x14575
KERN: 18 00007ffd1dc240c0 (+   0) 00007fcea6625260   <commpage> commpage_thread_exit + 0x00
KERN: kdebug> exitKERN: 1349: DEBUGGER: abort() called

Attachments (1)

DSCN0521.JPG (1.7 MB ) - added by TmTFx 10 months ago.
single core cpu 32 bit acquire_spinlock panic

Download all attachments as: .zip

Change History (8)

comment:1 by nephele, 10 months ago

this is also quite easily reproducible by attaching a debugger to something and killing the debugger (similar to 15223 maybe)

KERN: kdebug> contiunueKERN: PANIC: acquire_spinlock: attempt to acquire lock 0xffffffff81f225a0 twice on non-SMP system (last caller: 0x0000000000000000, value 81f225ac)
KERN: Welcome to Kernel Debugging Land...
KERN: Thread 588 "team 457 debug task" running on CPU 0
KERN: stack trace for thread 588 "team 457 debug task"
KERN:     kernel stack: 0xffffffff81f1e000 to 0xffffffff81f23000
KERN: frame                       caller             <image>:function + offset
KERN:  0 ffffffff81f222c8 (+  24) ffffffff8014db7c   <kernel_x86_64> arch_debug_call_with_fault_handler + 0x16
KERN:  1 ffffffff81f222e0 (+  80) ffffffff800ad638   <kernel_x86_64> debug_call_with_fault_handler + 0x88
KERN:  2 ffffffff81f22330 (+  96) ffffffff800aefc1   <kernel_x86_64> kernel_debugger_loop(char const*, char const*, __va_list_tag*, int) + 0xf1
KERN:  3 ffffffff81f22390 (+  80) ffffffff800af2be   <kernel_x86_64> kernel_debugger_internal(char const*, char const*, __va_list_tag*, int) + 0x6e
KERN:  4 ffffffff81f223e0 (+ 240) ffffffff800af627   <kernel_x86_64> panic + 0xb7
KERN:  5 ffffffff81f224d0 (+  48) ffffffff80077869   <kernel_x86_64> acquire_spinlock + 0x129
KERN:  6 ffffffff81f22500 (+  64) ffffffff80055614   <kernel_x86_64> ConditionVariable::_Notify(bool, int) + 0x34
KERN:  7 ffffffff81f22540 (+  32) ffffffff800c5429   <kernel_x86_64> finish_debugger_change(BKernel::Team*) + 0x49
KERN:  8 ffffffff81f22560 (+ 304) ffffffff800c56cd   <kernel_x86_64> nub_thread_cleanup(BKernel::Thread*) + 0x14d
KERN:  9 ffffffff81f22690 (+2336) ffffffff800c6d78   <kernel_x86_64> debug_nub_thread(void*) + 0x9b8
KERN: 10 ffffffff81f22fb0 (+  32) ffffffff8008a6a7   <kernel_x86_64> common_thread_entry(void*) + 0x37
KERN: 11 ffffffff81f22fd0 (+2114834480) ffffffff81f22fe0   
KERN: kdebug> continueKERN: acquire_advisory_lock(vnode = 0xffffffffa1eeeb80, flock = 0xffffffff81d91e90, wait = no)
Last message repeated 1 time

comment:2 by TmTFx, 10 months ago

Same for me with hrev 53337. It seems it happens for me when I boot from cd, and then I try to format a partition during the installation process, or booting to desktop soon after the Deskbar and the Haiku icon appear. The beta 1 on the same machine works correctly.

note: If during the installation process I don't modify the disk with disk manager (because I've already formatted the partition before) and I start the installation, after some files have been copied, an error occurs ( out of memory ). clicking on ok it let you go back to the installer but if you try to open disk manager the acquire_spinlock error happens.

by TmTFx, 10 months ago

Attachment: DSCN0521.JPG added

single core cpu 32 bit acquire_spinlock panic

comment:3 by mmlr, 10 months ago

Description: modified (diff)

comment:4 by waddlesplash, 10 months ago

Blocked By: 15223 added

All backtraces involve the kernel-level debugging system; so likely this and #15223 are really the same thing.

comment:5 by waddlesplash, 10 months ago

Should be (actually) fixed by hrev53339.

comment:6 by waddlesplash, 10 months ago

Resolution: fixed
Status: newclosed

Yep, works now.

comment:7 by nielx, 6 weeks ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.