Opened 2 months ago

Last modified 2 months ago

#15390 new bug

Most packages are hidden or missing

Reported by: axeld Owned by: stippi
Priority: normal Milestone: Unscheduled
Component: Applications/HaikuDepot Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When I launch HaikuDepot, I shortly see the complete list of packages. But they all go away after a short moment, and only four packages stay. It's always the same four packages.

Additional filters are applied correctly on these packages. When I install a package using the command line, or refreshing the repositories, all packages will be visible again, only to disappear, leaving the same four package behind.

I've deleted its settings file, and caches under /system/cache/package-repositories, and ~config/cache/HaikuDepot. Doesn't change a thing.

Attachments (2)

haiku-depot.out (5.2 KB ) - added by axeld 2 months ago.
Log output from a Terminal run (with caches removed)
haikudepot-trace.out (478.5 KB ) - added by axeld 2 months ago.
With -v trace

Download all attachments as: .zip

Change History (3)

by axeld, 2 months ago

Attachment: haiku-depot.out added

Log output from a Terminal run (with caches removed)

by axeld, 2 months ago

Attachment: haikudepot-trace.out added

With -v trace

comment:1 by axeld, 2 months ago

Judging from the output, this might give a clue:

~> pkgman list-repos
        Haiku
                base-url:  https://eu.hpkg.haiku-os.org/haiku/master/x86_gcc2/current
                url:       
                priority:  1
        HaikuPorts
                base-url:  https://eu.hpkg.haiku-os.org/haikuports/master/x86_gcc2/current
                url:       
                priority:  1
Note: See TracTickets for help on using tickets.