Opened 12 years ago

Closed 9 months ago

#1552 closed bug (fixed)

Mesa bug when starting Blender 2.1.1

Reported by: kvdman Owned by: kallisti5
Priority: normal Milestone: R1
Component: Kits/OpenGL Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Blender seems to start up and switch to a dark black full screen under Haiku but then crashes. Seems to be related to Mesa.

I've attached the debugging info.

Attachments (4)

blender.jpg (137.0 KB) - added by kvdman 12 years ago.
btnotfound.jpg (123.6 KB) - added by kvdman 12 years ago.
mesabt.jpg (87.2 KB) - added by kvdman 12 years ago.
blender1.jpg (176.8 KB) - added by kvdman 11 years ago.

Download all attachments as: .zip

Change History (27)

Changed 12 years ago by kvdman

Attachment: blender.jpg added

comment:1 Changed 12 years ago by korli

backtrace ?

comment:2 Changed 12 years ago by kvdman

Hi,

This doesn't kill Haiku, but just Blender just crashes and gives the option of debugging, which is what I posted in the screenshot.

I'm not sure how to do a backtrace in this case, or if you can?

comment:3 Changed 12 years ago by umccullough

Once in GDB - you should be able to use the "bt" command to run a backtrace.

comment:4 Changed 12 years ago by kvdman

Hi,

the problem is, it doesn't go into gdb. it just crashes and gives an option to debug. i guess gdb only gets invoked when haiku completely crashes (which it doesn't in this case); with the bug i just filed for metos (1553) haiku does crash and then i could do the backtrace.

comment:5 Changed 12 years ago by stippi

When you actually click on the "option to debug", that's when you will get a Terminal with gdb to debug the program. In that Terminal, type "bt". GDB is presented in two ways, the normal way is the Terminal thing I just described, but for vital system servers (like the app_server or the input_server), GDB is run in that weird full screen mode.

comment:6 Changed 12 years ago by korli

I tried installing blender2.11-beos-5.0-i386.zip. It seems to depend on python. Which package should I use ? Please provide a stacktrace.

comment:7 Changed 12 years ago by kvdman

Hi,

'sh: bt: command not found'

See the screenshot attached.

Also, I'm using libypthon2.4.so in /home/config/lib

You need to make a link in the same directory, and rename it libpython2.1.so

Changed 12 years ago by kvdman

Attachment: btnotfound.jpg added

comment:8 Changed 12 years ago by kvdman

Ok, sorry don't know what was going on. Got the backtrace and attached it! Sorry for the confusion. Definitely seems to be MESA related...

Changed 12 years ago by kvdman

Attachment: mesabt.jpg added

comment:9 Changed 12 years ago by kvdman

I wanted to test MESA software renderer from BeOS Max v4b on Haiku to see if Blender would work with this version, but can't locate the binary, just the source. It's not located in the same place as in Haiku, and a search doesn't reveal it. Would it be named something else?

comment:10 Changed 12 years ago by umccullough

oh, maybe gdb uses sc (stackcrawl) instead of bt (backtrace) - I can never remember :)

comment:11 Changed 11 years ago by korli

I don't experience a crash, but a infinite looping thread with splash().

comment:12 Changed 11 years ago by kvdman

Blender loads now, but I can't select any of the menu items at all. Notice the errors in the terminal from the screenshot attached (blender1.jpg)

Changed 11 years ago by kvdman

Attachment: blender1.jpg added

comment:13 Changed 11 years ago by emitrax

Any updates on this one ?

comment:14 in reply to:  13 Changed 11 years ago by korli

Replying to emitrax:

Any updates on this one ?

I tried a few weeks ago, and couldn't understand what happens: Blender seems to loop waiting for an event. The Blender sources are not easy to find. I talked to aldeck about Blender, and, in a way, an up to date port would help to fix this issue.

comment:15 Changed 11 years ago by emitrax

An up to date port for haiku just sound great. But if the 2.1.1 runs fine on BeOS, there seems to be a compatibility problem that need to be fix. Is that the case?

comment:16 in reply to:  15 Changed 11 years ago by korli

Replying to emitrax:

An up to date port for haiku just sound great. But if the 2.1.1 runs fine on BeOS, there seems to be a compatibility problem that need to be fix. Is that the case?

Yes it's what I implied. At least, the problem is not linked to OpenGL.

comment:17 Changed 11 years ago by kvdman

Here's some more information...

This is the last version of Blender for BeOS that I was testing:

http://www.haikuware.com/start-download/multimedia/graphics/3d-tools/blender

You'll need python, and link it to libpython1.5.so in order for Blender to find it. I've used the old python here:

http://www.haikuware.com/view-details/development/language/python

And the newer version at Haiku Ports with similar results:

http://dev.haiku-os.org/attachment/ticket/1552/blender1.jpg

Sadly, the sources to that version of Blender for BeOS are nowhere to be found, but I came across this:

http://ftp.iasi.roedu.net/mirrors/blender.org/source/chest/blender_2.03_tree/glut-beos/

Also, Zeta had a newer version of Blender and has a patch:

http://ghost.m-phasis.de/files/blender_ZETA_patch_20051023.zip

That patch is hosted at a project at sourceforge:

http://projects.blender.org/projects/ghost/

Which states:

'To free GHOST from all ties with Blender & produce a new standard in OpenGL toolkits (replacing GLUT for C and C++ projects).'

Perhaps GHOST is an issue when building Blender on Zeta/BeOSs since they provided the latest patch to get it running on BeOS/Zeta.

See screenshots:

http://ghost.m-phasis.de/

comment:18 Changed 10 years ago by korli

blender2.11-beos-5.0-i386.zip seems to work a bit now. Could still be buggy though.

comment:19 Changed 6 years ago by kallisti5

Is this still an issue? We need to test the beos blender release and see the state of it.

comment:20 Changed 6 years ago by kallisti5

Owner: changed from korli to kallisti5
Status: newassigned

comment:21 Changed 5 years ago by diver

hrev48280. I've tested blender+2.11.zip from http://haikuware.com/directory/view-details/multimedia/graphics/3d-tools/blender-211

It works, however it bundles libGL.so from R5. With libGL.so from mesa-7.9.2-10-x86_gcc2.hpkg blender starts but menus don't react on clicks.

Last edited 5 years ago by diver (previous) (diff)

comment:22 Changed 13 months ago by cocobean

Tested on hrev 51880 x86. Blender 2.11b-4 menus work. Still unstable though (tends to crash).

Tested on hrev 51880 x86_64. Blender 2.79-8 menus work. Seems pretty reliable.

Last edited 13 months ago by cocobean (previous) (diff)

comment:23 Changed 9 months ago by scottmc

Resolution: fixed
Status: assignedclosed

Closing this one. If there are still issues with Blender and/or Mesa those can be reported at HaikuPorts.

Note: See TracTickets for help on using tickets.