Opened 12 years ago

Closed 12 years ago

#1553 closed bug (fixed)

Metos crashing..

Reported by: kvdman Owned by: axeld
Priority: critical Milestone: R1/alpha1
Component: Kits/Application Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This might have to do with the last bug I filed for Blender. In particular, I see an error [tcsetpgrp failed in terminal_inferior: Invalid arguement]?

Although it shows a bug in the app server I believe.

Screenshot attached.

Attachments (1)

metoos.jpg (156.3 KB) - added by kvdman 12 years ago.

Download all attachments as: .zip

Change History (16)

Changed 12 years ago by kvdman

Attachment: metoos.jpg added

comment:1 Changed 12 years ago by kvdman

The Blender bug I'm referring to is here:

http://dev.haiku-os.org/ticket/1552

Blender is here:

http://bebits.com/app/61

comment:2 Changed 12 years ago by kvdman

Sorry, meant to add the Metos location here not blender:

http://bebits.com/app/3066

comment:3 Changed 12 years ago by diver

Looks like a dup of bug #195. But at least this crash is reproducible now.

comment:4 Changed 12 years ago by bonefish

It would help tremendously to get a back trace (type "bt" in gdb).

The "tcsetpgrp failed..." output is unrelated. It's an unimplemented feature in our gdb port and you'll see it on every crash.

comment:5 Changed 12 years ago by kvdman

Ok thanks for that info.. hmm no way to attach additional files with this system?

comment:7 in reply to:  5 Changed 12 years ago by bonefish

Replying to kvdman:

Ok thanks for that info.. hmm no way to attach additional files with this system?

I would try the "Attach File" button in the "Attachments" section. :-)

comment:8 Changed 12 years ago by kvdman

Haha, I see it now! Thanks.

Hope the info is useful, bye!

comment:9 Changed 12 years ago by jonas.kirilla

See #195, #266 and #1166.

(MetOS, Cortex, ArtPaint, FontDemo, ... all palette window related?)

comment:10 Changed 12 years ago by kvdman

Hi Jonas,

I've tested ArtPaint and FontDemo as you mention on rev22490, and they run fine and don't give the same error or any error.

Cortex will lock my system, but I think this is a known bug.

Metos will actually go directly to gdb.

comment:11 Changed 12 years ago by jonas.kirilla

The app_server does crash, even on a current release, if you launch like 7 copies of FontDemo simultaneously. I haven't used Metos myself, but perhaps Metos makes use of multiple floating palette windows, ending in the same result. I don't know.

comment:12 Changed 12 years ago by kvdman

I've tried to reproduce the FontDemo app crashing by opening up 7 copies, but was unable to...

comment:13 Changed 12 years ago by jonas.kirilla

I'm sorry, kvdman. I assumed you had not tried copies. My apologies.

comment:14 Changed 12 years ago by axeld

Priority: normalcritical
Status: newassigned

comment:15 Changed 12 years ago by axeld

Milestone: R1R1/alpha
Resolution: fixed
Status: assignedclosed

Fixed in hrev22549.

Note: See TracTickets for help on using tickets.