Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#168 closed bug (duplicate)

Corrupted icons and shutdown hang

Reported by: diver Owned by: axeld
Priority: high Milestone: R1
Component: Applications Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

There are some issues with shutdown: Tired of manually starting tracker, i've edited /system/boot/Bootscript by adding "launch Tracker" string and rebooted so Bootscript to sync with bfs. Shutdown showed "Tiding things a bit" message (which i think is sync) about a minute (this because of http://www.haiku-os.org/bugzilla/show_bug.cgi?id=104) and then restarted. Upon boot Tracker starts just fine, but when i tryed to shutdown haiku, shutdown stopped on Tracker, after several seconds Kill Application button became enabled, but clicking on it doesn't do anything. Then i tryed Ctrl+Alt+Del thing to bring up Team Monitor to kill Tracker from there. After selecting Tracker from Team Monitor and pressing Kill Application button Team Monitor just lockedup, so i needed to force restart. After restart Trash and Home icons on the Desktop got corrupted and shows as black squares (you could see it on a screenshot). So now i'm getting the same bug whenever i try to properly shutdown or restart Haiku. And corrupted black icons too. Tested with rev16399 under vmware.

Attachments (1)

corrupted_icons.PNG (55.3 KB ) - added by diver 14 years ago.
black corrupted icons

Download all attachments as: .zip

Change History (10)

comment:1 by diver, 14 years ago

Summary: shutdownCorrupted icons and shutdown hang

comment:2 by diver, 14 years ago

severity: normalmajor

comment:3 by diver, 14 years ago

op_sys: AllHaiku

comment:4 by diver, 14 years ago

rep_platform: AllX86

by diver, 14 years ago

Attachment: corrupted_icons.PNG added

black corrupted icons

comment:5 by daneel@…, 14 years ago

(In reply to comment #0)

There are some issues with shutdown: Tired of manually starting tracker, i've edited /system/boot/Bootscript by adding "launch Tracker" string and rebooted so Bootscript to sync with bfs. Shutdown showed "Tiding things a bit" message (which i think is sync) about a minute (this because of http://www.haiku-os.org/bugzilla/show_bug.cgi?id=104) and then restarted. Upon boot Tracker starts just fine, but when i tryed to shutdown haiku, shutdown stopped on Tracker, after several seconds Kill Application button became enabled, but clicking on it doesn't do anything. Then i tryed Ctrl+Alt+Del thing to bring up Team Monitor to kill Tracker from there. After selecting Tracker from Team Monitor and pressing Kill Application button Team Monitor just lockedup, so i needed to force restart. After restart Trash and Home icons on the Desktop got corrupted and shows as black squares (you could see it on a screenshot). So now i'm getting the same bug whenever i try to properly shutdown or restart Haiku. And corrupted black icons too. Tested with rev16399 under vmware.

I think its a duplicated bug of this: http://www.haiku-os.org/bugzilla/show_bug.cgi?id=82

comment:6 by axeld, 14 years ago

The shutdown part shouldn't apply anymore.

* This bug has been marked as a duplicate of #82 *

comment:7 by axeld, 14 years ago

Status: newclosed

comment:8 by axeld, 14 years ago

Resolution: duplicate

comment:9 by korli, 13 years ago

bug_group: developers
Note: See TracTickets for help on using tickets.