Opened 11 years ago

Closed 11 years ago

#1819 closed bug (fixed)

ProcessController/Deskbar crash in AttachScrollers()

Reported by: drackham Owned by: jackburton
Priority: normal Milestone: R1/alpha1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This may be the same bug as #1561. I would have added it to that ticket but bug #1794 (unable to add comments to tickets) is still afflicting me.

Test Procedure:

  1. Open a few applications (I opened three Terminals)
  2. Click on ProcessController in the Deskbar
  3. Navigate to "Threads and CPU Usage"->app_server
  4. If there are not enough threads listed to cause scrollers to appear at the top and bottom of the list return to step 1.
  5. Move mouse pointer over list of app_server's threads.

Result:

Deskbar encounters an error which prevents it from continuing. The attached gdb output implicates a call to BPrivate::BMenuWindow::AttachScrollers ()

Attachments (2)

gdb.txt (2.9 KB) - added by drackham 11 years ago.
gdb backtrace of crashed Deskbar
shot.PNG (71.3 KB) - added by jackburton 11 years ago.
working scrollers

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by drackham

Attachment: gdb.txt added

gdb backtrace of crashed Deskbar

comment:1 Changed 11 years ago by drackham

Ugh... forgot to mention:

This is in hrev24011 built under R5 running on real hardware (PIII-667 320MB ram)

comment:2 Changed 11 years ago by jackburton

Owner: changed from axeld to jackburton

comment:3 Changed 11 years ago by jackburton

Status: newassigned

comment:4 Changed 11 years ago by jackburton

This seems to have been fixed by hrev24044 too. Can you confirm ?

comment:5 Changed 11 years ago by drackham

No, it still occurs in hrev24044 for me. The gdb output looks the same too.

comment:6 Changed 11 years ago by jackburton

Milestone: R1R1/alpha1

I still can't reproduce. To make sure I didn't have any uncommitted local change, I downloaded the vmware image of hrev24049 from haiku-files. And I can't reproduce the problem with that image either (see screenshot).

Changed 11 years ago by jackburton

Attachment: shot.PNG added

working scrollers

comment:7 Changed 11 years ago by jackburton

Do you have a SMP/Multi core machine by chance ?

comment:8 Changed 11 years ago by drackham

I don't get the crash from just a long list of teams in ProcessContoller. Continue one level deeper to the list of threads in the app_server team. If that list is so long as to need scrollers I get a crash when I mouseover it.

I still see it in 24060. I'm using a single processor PIII-667 with 320MB ram.

comment:9 Changed 11 years ago by jackburton

Resolution: fixed
Status: assignedclosed

I could reproduce it, thank you. It's fixed in hrev24094.

Note: See TracTickets for help on using tickets.