Opened 11 years ago

Closed 4 years ago

#1846 closed bug (fixed)

Media does not retain preferred settings

Reported by: cebif Owned by: korli
Priority: normal Milestone: R1
Component: Preferences/Media Version: R1/pre-alpha1
Keywords: Cc: mauricek
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The Media application does not retain its settings after a reboot. Restarting Media from inside the application does not lose preferred settings. 1) Open Preferences/Media. 2) Change settings to whatever is preferred. 3) Restart the Media from restart button either the video settings tab or the first audio settings tab. The result is the settings have been retained according to your preferences. The expected behavior. If you go through the steps to 2 or 3 inclusive, then reboot Haiku the settings have gone back to defaults. This is reproduceable every time. I was testing in hrev24008 on its own partition.

Change History (15)

comment:1 Changed 11 years ago by mauricek

Cc: mauricek added

comment:2 Changed 11 years ago by mauricek

Is this one still valid? I cannot reproduce it anymore and remember that I did some work related to this quite some time ago. Could you please verify that this bug has been resolved by now.

comment:3 Changed 11 years ago by idefix

I can confirm this bug is still valid.

I have a SoundBlaster Live and every time I boot into Haiku, I have to set the 'AC97 Mixer'-settings again. (Specifically: Media Preferences -> Emuxki SB Live -> AC97 Mixer -> uncheck 'Line In' Mute)

comment:4 Changed 11 years ago by nutela

I have a different experience; Media Preferences are not saved when the "Restart Media Services" is clicked (media_server restarted).

Using Echo24 driver (Echo Mia Midi)

Rev 25950

comment:5 Changed 11 years ago by cebif

How my experience works out and the way I reported this bug relates to: driver ich_ac97 for a nvidia nforce2 chipset that contains Realtek ALC655 sound.

comment:6 Changed 10 years ago by nutela

I've also noticed that "Refuse input format changes" and "Refuse output format changes" checkboxes in the "Setup" tab are always checked (I don't know what they mean however) and unchecking them and restarting Media Prefs checks them again.

comment:7 Changed 9 years ago by HAL

I still have the same bug using a new motherboard and sound chip. The motherboard is: Abit KN8 SLI The sound chip is: Realtek ALC850. Something new I notice now is: either a media preferences restart or closing and opening media preferences, after selecting real time video check box, becomes unselected again. Real time audio settings if unselected, become selected again after a media preferences restart. The settings only stay at there defaults, like the settings file is read only. I don't know if this is so but will check the file. All other things remain the same.

comment:8 Changed 9 years ago by HAL

I checked the media settings folder and files. They seem to have the correct permissions.

comment:9 Changed 9 years ago by HAL

I was testing with hrev34838.

comment:10 Changed 9 years ago by HAL

Tested again with hrev35341 gcc4 hybrid build and the media settings in the Auich nVidia, AC97 mixer settings and Recording tab settings are rememberd now after a reboot. The Audio settings, Enable realtime audio, checkbox is still not retained after a restart and the same applies to Video Settings, Enable real time video, checkbox when ticked.

comment:11 Changed 9 years ago by HAL

Some things have changed testing with hrev36476 GCC4 Hybrid.

  1. Doing a media restart after my prefered settings, become set back to defaults.
  2. Not doing a media restart but rebooting, the Media preferences are correctly left at my preferences.

In 1 for one of the other users comments this applied before the revision I'm now testing. Hardware is: vendor 10de: nVidia Corporation device 0059: CK804 AC'97 Audio Controller

comment:12 Changed 8 years ago by Coldfirex

Unable to reproduce in R39551 GCC2Hybrid. Opened MediaPlayer, selected loop sound and video, rebooted, and settings were still intact.

comment:13 Changed 8 years ago by korli

Actually it's about the Media preflet, not the MediaPlayer.

comment:14 Changed 8 years ago by Coldfirex

Sorry about that. I was still unable to reproduce, with and without using the restart media services, after making changes and rebooting. hrev39551 gcc2hybrid under virtualbox 3.2.10 (ich a97).

comment:15 Changed 4 years ago by Barrett

Resolution: fixed
Status: newclosed

Not reproducible anymore, closing as fixed.

Tested under both virtualbox and native hardware. Also the real-time checkbox was removed some time ago. However if some of you can still reproduce it just let me know i will reopen it.

Note: See TracTickets for help on using tickets.