Opened 13 years ago

Closed 8 years ago

#190 closed bug (fixed)

[Media] prefs isn't font sensitive (easy)

Reported by: diver Owned by: stippi
Priority: normal Milestone: R1
Component: Preferences/Media Version: R1/Development
Keywords: Cc: jalopeura@…
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description (last modified by stippi)

Media prefs isn't font sensetive. Tested with default font settings under vmware with rev16444. Screenshots will follow. Oh, btw, isnt' Media should say anything if it can't load media_server?

Attachments (6)

Media_1.PNG (30.7 KB) - added by diver 13 years ago.
audio settings
Media_2.PNG (29.8 KB) - added by diver 13 years ago.
video settings
Media_3.PNG (22.9 KB) - added by diver 13 years ago.
gui
Media_4.PNG (27.6 KB) - added by diver 13 years ago.
Big font problems
diff.txt (11.5 KB) - added by jalopeura 10 years ago.
Patch
diff.2.txt (27.6 KB) - added by jalopeura 10 years ago.
Incomplete Patch

Download all attachments as: .zip

Change History (40)

Changed 13 years ago by diver

Attachment: Media_1.PNG added

audio settings

Changed 13 years ago by diver

Attachment: Media_2.PNG added

video settings

comment:1 Changed 13 years ago by korli

hopefully fixed in revision 16450.

comment:2 Changed 13 years ago by korli

Resolution: fixed

comment:3 Changed 13 years ago by korli

Status: newclosed

comment:4 Changed 13 years ago by diver

attachments.isobsolete: 01

comment:5 Changed 13 years ago by diver

Resolution: fixed

comment:6 Changed 13 years ago by diver

Status: closedreopened

Changed 13 years ago by diver

Attachment: Media_3.PNG added

gui

comment:7 Changed 13 years ago by korli

Resolution: fixed

comment:8 Changed 13 years ago by korli

Fixed

comment:9 Changed 13 years ago by korli

Status: reopenedclosed

comment:10 Changed 13 years ago by diver

Ok, if you try to set 14th font size or larger you could see that several text labels wont fit in and will cut off.

comment:11 Changed 13 years ago by diver

Resolution: fixed

comment:12 Changed 13 years ago by diver

Summary: Media prefs isn't font sensetive[Media] prefs isn't font sensetive

comment:13 Changed 13 years ago by diver

Status: closedreopened

Changed 13 years ago by diver

Attachment: Media_4.PNG added

Big font problems

comment:14 Changed 11 years ago by diver

Component: - Preferences- Preferences/Media
Platform: All
Summary: [Media] prefs isn't font sensetive[Media] prefs isn't font sensetive (easy)

comment:15 Changed 11 years ago by diver

Summary: [Media] prefs isn't font sensetive (easy)[Media] prefs isn't font sensitive (easy)

comment:16 Changed 11 years ago by diver

Could this be fixed in hrev24765?

comment:17 Changed 11 years ago by stippi

Description: modified (diff)

The patch from hrev24765 just touched the window itself, ie the container views. This bug might also refer to the Mixer node's view and other node supplied views which are embedded into the preflet. When I looked at it (I just get the Mixer view though), it looked very fine to me. Could be that the Mixer is already properly layouting itself. If someone has the time, please test the preflet with different font sizes and report your findings. :-)

comment:18 Changed 11 years ago by axeld

The DefaultMediaTheme is supposed to do all the layout - currently it's not that pretty and not very powerful, though. Since we now have a layout engine, it should use that one instead.

comment:19 Changed 10 years ago by jalopeura

Cc: jalopeura@… added
Version: R1 development

Updating to use the system layout engine.

comment:20 in reply to:  19 ; Changed 10 years ago by stippi

Replying to jalopeura:

Updating to use the system layout engine.

Just to make sure: Do you mean you are working on it? Or did you already work on it and forgot to attach the patch?

comment:21 in reply to:  20 Changed 10 years ago by jalopeura

Replying to stippi:

Just to make sure: Do you mean you are working on it? Or did you already work on it and forgot to attach the patch?

I am working on it.

comment:22 Changed 10 years ago by jalopeura

Attaching a patch, with the following notes and caveats:

  • Checked font sizes 12 and 18.
  • This also fixes ticket #1801; the text mentioned there is now visible.
  • Everything but the audio mixer had already been updated to use the layout manager, so that's all this patch touches.
  • BOptionPopUp and BSlider are not layout-friendly (at least, they don't accept a constructor without a BRect - although BChannelSlider did accept such a constructor), so instead they take a default BRect of (0,0,50,100).
  • BSlider and BChannelSlider have not been tested - with my "hardware"(vmware emulating sb16), I get no slider controls at all. BOptionPopUp looks fine, even with the non-layout constructor.
  • I changed the MakeViewFor() functions in DefaultMediaTheme so the BRect parameter defaults to NULL. They could probably be taken out entirely, as I believe they are all used internally only, except one which is most likely only called from MediaWindow. However, I wasn't sure, so I left them in to be safe.

Changed 10 years ago by jalopeura

Attachment: diff.txt added

Patch

comment:23 Changed 10 years ago by stippi

Owner: changed from korli to stippi
Status: reopenednew

comment:24 Changed 10 years ago by stippi

I've finally managed to test this patch (sorry for the delay), but I am sorry to say that it doesn't work at all yet. The problem here is that you haven't had a chance to test parameter webs with channel sliders. Do you want to keep working on this? The HDA driver or the OpenSound package may work in one of the emulators, so you could check your patch with that. Is this an option?

comment:25 Changed 10 years ago by jalopeura

I was concerned about being unable to test those sliders. I'll look into it and see if I can get some to show up for me.

comment:26 Changed 10 years ago by korli

Maybe you can try on VirtualBox with the virtual ICH audio device.

Changed 10 years ago by jalopeura

Attachment: diff.2.txt added

Incomplete Patch

comment:27 Changed 10 years ago by jalopeura

I updated the main window to use layout and ChannelSliders are working for me, but I'm still having the following two problems:

1) The container view on the main window doesn't resize with the window, even though the list view and the separator bar do. I can't figure out what I'm doing differently with that view to make it stay fixed in size.

2) When DefaultMediaTheme returns a single group (in a scroll view), it works fine - the scroll view is sized to the container view and the scroll bars allow you to see the entirety of the contained group view. But when it returns multiple groups (in scrolls views in a tab view), the scroll views are sized to the contained group views, and not to the containing tab view, so you can't see the whole view.

I have spent the last three days trying to track down these issues and have been unsuccessful, so if anyone has any ideas, please let me know. I'd even be willing to delve into the BTabView class if someone is reasonably certain that's where the problem lies.

comment:28 Changed 10 years ago by stippi

I am going to have a look, sorry for the lag!

comment:29 Changed 9 years ago by diver

Any news Stephan?

comment:30 Changed 9 years ago by stippi

The patch introduced a number of issues and regressions, IIRC, that's why I didn't apply it.

comment:31 Changed 9 years ago by diver

Version: R1/pre-alpha1R1/Development

comment:32 Changed 9 years ago by pulkomandy

Has a Patch: set

comment:33 Changed 8 years ago by jalopeura

The issues illustrated by the screenshots no longer occur (at least with the controls that show up for my setup). At font size 18, some of the text is shortened (gracefully, with '...'), but no text simply stops short, or gets covered up by other controls.

When I worked on this previously, I came to the conclusion that at least part of the problem was bugs in the layout code; perhaps these have been fixed since then? If anyone is still having this problem, I'd be willing to work on it again, if I can just reproduce it.

comment:34 Changed 8 years ago by stippi

Resolution: fixed
Status: newclosed

I think the issues have been fixed by Alex Wilson in the meantime. Alex, please reopen if this was not supposed to be closed.

Note: See TracTickets for help on using tickets.