Opened 11 years ago

Last modified 2 years ago

#1903 assigned bug

ifconfig: media selection option is available but not supported.

Reported by: siarzhuk Owned by: nobody
Priority: low Milestone:
Component: Kits/Network Kit Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

[Haiku hrev24319] Yesterday I have asked on IRC about possibility to switch network media to some non-default value under Haiku. mmu_man was so kind that very quickly added media selection option into ifconfig. Following tests and comments in commits e-mail list show me that the problem is a bit deeper. :-)

I register this ticket just to document "media option" issue. At the moment this looks like a bug: option is available for user selection in ifconfig but is not supported by Haiku network. Should we rollback media option changes or finish media change possibility in Haiku network?

Some words about situation which forces me to switch network media: I have AVM FritzBox! SL DSL modem with possibility to connect PC with ethernet. Second actor of this drama is my laptop with embedded rtl8139 network. In default case laptop network configure media to 100 MBit but resulting connection is non-usable - about 40-50%% of packets are lost. This situation is reproducible under all operating systems I use: R5, Haiku, FreeBSD, Windows. The solution is manual change of media type to 10 MBit. This fixes my problem. At the moment I have hardcoded 10 MBit media mode in my local copy of Haiku rtl8139 driver. I can use and test network under Haiku now so this problem is not urgent or significant for me. ;-)

Change History (1)

comment:1 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned
Note: See TracTickets for help on using tickets.