Opened 11 years ago

Last modified 7 days ago

#1902 assigned bug

[Media_Server] play StartUp sound on sucessful start/restart

Reported by: cebif Owned by: korli
Priority: normal Milestone: R1
Component: Servers/media_server Version: R1/Development
Keywords: Cc: mdisreali@…, black.belt.jimmy@…
Blocked By: Blocking: #4440, #6519
Has a Patch: no Platform: All

Description (last modified by mmlr)

If I copy some *wav sounds to /boot/beos/etc/sounds, then apply wav sounds to events in Sounds preferences application, when any event occurs that is set with a sound it wont play.If I reboot the BeStartup.wav wont play if I have set it.

To reproduce:
1) Open Preferences/Sounds.
2) Assign a *wav sound like BeStartup.wav to BeStartup.
3) Close the Sounds application.
4) Reboot

On reboot the BeStartup.wav sound does not play. This is reproduceable every time. On openning Preferences Sounds the assigned sound is seen to be still set but it wont play. A sound will play if you click play in the Sounds application though. The version I was testing was: hrev24280 on its own partition.

Change History (17)

comment:1 Changed 9 years ago by mmlr

Blocking: 4440 added

(In #4440) Duplicate of #1902.

comment:2 Changed 9 years ago by mmlr

Description: modified (diff)

comment:3 Changed 9 years ago by bga

Startup sound is not implemented in Haiku. The event is there but nothing in the code actually tries to play it (in BeOS, the media server is the one that plays this sound when it starts). Here with me it works perfectly when I set the system beep, for example.

comment:4 in reply to:  3 Changed 9 years ago by koki

Replying to bga:

Startup sound is not implemented in Haiku.

Should this be a "known issue" for the release notes?

comment:5 Changed 9 years ago by bga

I guess so. On the other hand, actually adding it should be a pretty simple change.

comment:6 Changed 9 years ago by Disreali

Not that we have a start-up sound right now, but it would be great for r1a1 users to be able to 'hear' the desktop come up.

comment:7 Changed 9 years ago by jackburton

Summary: Sounds wont play when set for events in Preferences, SoundsStartup sound wont play when set for events in Preferences, Sounds

This is pretty trivial to implement: we just have to decide WHO should play the sound. IOW: just calling system_beep("startup") (or whatever it's called) should do the trick. Should the media_server do that ? or the media_addon_server ? or the tracker ?

comment:8 Changed 9 years ago by jackburton

Component: Preferences/Sounds- General
Owner: changed from marcusoverhagen to nobody

comment:9 Changed 9 years ago by korli

Resolution: fixed
Status: newclosed

Fixed in hrev34189.

comment:10 Changed 9 years ago by Disreali

Cc: mdisreali@… added
Resolution: fixed
Status: closedreopened
Version: R1/pre-alpha1R1/Development

I am experiencing this on real hw since hrev35991. Most recent tested is hrev36336.

comment:11 Changed 8 years ago by Coldfirex

Confirmed still existing in hrev39551 gcc2hybrid in virtualbox.

comment:12 in reply to:  3 Changed 8 years ago by Disreali

Component: - GeneralServers/media_server
Summary: Startup sound wont play when set for events in Preferences, Sounds[Media_Server] play StartUp sound on sucessful start/restart

Replying to bga:

Startup sound is not implemented in Haiku. The event is there but nothing in the code actually tries to play it (in BeOS, the media server is the one that plays this sound when it starts).

BeOS also played the StartUp sound every time one pressed the "Restart Media Services" button in the Media preflet and the service successfully restarted. As it currently is with hrev40230, I have no idea if sound actually works when I startup nor when I restart the media service. I have to open the Sounds preflet and attempt to play a sound there to determine if the media service is working properly. We should just duplicate the BeOS behaviour of having media_server play the StartUp sound every time. That way one can hear if the sound actually works, and if not can just press the restart button again until a sound plays.

comment:13 Changed 8 years ago by axeld

Owner: changed from nobody to korli
Status: reopenedassigned

Of course, the media_server is supposed to play the startup sound on every launch. I assign this one to korli, as I think he actually implemented this a while ago (it might just not work anymore for whatever reason).

In any case, again, the problem you describe is still a bug, and cannot be used as an argument for the viability of any feature.

comment:14 Changed 6 years ago by dsjonny

The "Startup" sound does not plays for me when media_server (re)starts.

comment:15 Changed 4 years ago by bbjimmy

Cc: black.belt.jimmy@… added

comment:16 Changed 4 years ago by Barrett

I think this bug is caused by the delay of the media_server at startup. In my pc with HDA audio if i try to play audio just once the media_server has been restarted there are circa 10 seconds of silence. This is not a delay itself, but the MediaPlayer begin to play and in 5-10 secs the audio begin to work. I don't know if it's caused by the timesource behaving uncorrectly or more probably the audio mixer not correctly operating at startup.

comment:17 Changed 7 days ago by waddlesplash

Blocking: 6519 added
Note: See TracTickets for help on using tickets.