Opened 11 years ago

Last modified 7 months ago

#1904 new bug

Hardware cursor not working on Matrox G200

Reported by: biffuz Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Graphics/Matrox Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

On my Matrox G200 8 Mb SGRAM AGP 2x, hardware mouse cursor acceleration does not work, neither in Haiku or BeOS R5. Under ZETA 1.2 it works, and with the same driver! (this is the latest revision, but this happened with older ones, too)

Oh, and in the Ticket Properties, the Matrox driver doesn't even appear...

Change History (4)

comment:1 Changed 11 years ago by axeld

Component: Drivers/GraphicsDrivers/Graphics/Matrox

Haiku currently does not support a hardware cursor at all. Since you have a problem on BeOS, we can keep this bug open to see remember checking if there are any issues with that driver once Haiku does support a hardware cursor.

And thanks for the note, I've added the Matrox driver as component.

comment:2 Changed 9 years ago by axeld

Owner: changed from axeld to nobody
Version: R1/pre-alpha1R1/Development

comment:3 Changed 5 years ago by humdinger

We do have hardware cursors now, don't we?
Question is, is the Matrox card still alive... :)

I do have a hardware cusor issue, that I'll open a new ticket for.

comment:4 Changed 7 months ago by cocobean

hrev52017 x86_64 and Matrox driver v0.33 (Nov 2, 2009) reviewed. Confirmed with PulkoMandy that Haiku now supports hardware mouse cursor acceleration. The Matrox driver supports hardware mouse cursor acceleration as well for all Matrox G-series and Millenium cards supported (if mga.settings=true, false for DualHead setups).

Technically from code review, it looks like the issue was fixed by the developer(rudolfc) in Y2009. We can close this ticket based on this info.

Last edited 7 months ago by cocobean (previous) (diff)
Note: See TracTickets for help on using tickets.